dev-lang/ruby: add 2.4.5
authorHans de Graaff <graaff@gentoo.org>
Thu, 18 Oct 2018 05:35:57 +0000 (07:35 +0200)
committerHans de Graaff <graaff@gentoo.org>
Thu, 18 Oct 2018 05:36:12 +0000 (07:36 +0200)
Bug: https://bugs.gentoo.org/668904
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

dev-lang/ruby/Manifest
dev-lang/ruby/ruby-2.4.5.ebuild [new file with mode: 0644]

index f7b143505eb6d3758421c24f3fc3c25c8736e99a..0c634fb1f9f3b7540425dd873907d57421cebffc 100644 (file)
@@ -1,5 +1,6 @@
 DIST ruby-2.3.7.tar.xz 11438124 BLAKE2B 4f7e0422291794b254cb80edd2f0841bbc1e85cd62635024b6d43b23b1bcdc512d92b57d8885b253465cc8ef3c6cbcec97a6ef239dc11cc8b252e941d25e0487 SHA512 fd91c8db3d3aa4cc962a62f27b4d1a71f6b5567ab836e6dbfbbb1553eb269d11e12faf9e36af6c489c33b54fd89dab99bfe81a563158b704877f0628d6f5bc5a
 DIST ruby-2.4.4.tar.xz 10049304 BLAKE2B 76bb2c3f63cda8e6f3814c74dded23568b2f7f12036d745bf55fc4a68e281ef3ae0fe29bf8e194db71f72e724ffe750a31bec9246ad1c01eb05ed93512a6422e SHA512 4dc112a149273d4221484ccbf1260c6c5fcad7e0a6e4bc91e4ef69cbc093d3191f7abd71420f80d680f8ea5d111e6803ba2af32166aa501913639e6d5696fde0
+DIST ruby-2.4.5.tar.xz 10064712 BLAKE2B 0846125e617b43ea302b4c5309b20503577937865d445a6fee766323a188aa552d3a13740c3d38c7be812b19bffb2474021cb7b368cc144d51ea771552f62769 SHA512 658f676c623109f4c7499615e191c98c3dd72cfcaeeaf121337d0b8a33c5243145edd50ec5e2775f988e3cd19788984f105fa165e3049779066566f67172c1b4
 DIST ruby-2.5.1.tar.xz 11348108 BLAKE2B ea1019a81f96169ab8d435215362b36b098df373ac4f53ecda328686ec2c13204a38c66bb1bf9504d18e1762e7e6ae277bab3b16bb53b8e628962df715769f3b SHA512 31bacf58469953282cd5d8b51862dcf4b84dedb927c1871bc3fca32fc157fe49187631575a70838705fe246f4555647577a7ecc26894445a7d64de5503dc11b4
 DIST ruby-patches-2.3.7.tar.bz2 3030 BLAKE2B 7c1e80ff0569a03672f53820c665933056b46bcf791c9132cb9f358f72df693749f02da65ca7469c3dd0f652d7dc7bfaa03dccd4eb900562361876023fb65b42 SHA512 54cc3f2bfd1967b8558736e5a5240b886a56b22defca5813f45b1f4dca9af169b4d59d60b327ec8411e824970ac6da1cec53cfc31833403742e9d6941e5a78f1
 DIST ruby-patches-2.4.4.tar.bz2 2898 BLAKE2B e46502dbb0aa25c3d71693a6c04b433bd4de60f194cdd283517c4b08da190356885d9bca4a6765402088185fa8ec681156e8e8eecf0703a2c1ea7bb81adc0bf9 SHA512 d767d43c7df737469247e42e1c4205b8c6850c8f335a2869c884f145c037e9bab10492cc7cd2903f5c33e232cdc5bbdabb3e8da837c7bf420b9d58d1d33149ed
diff --git a/dev-lang/ruby/ruby-2.4.5.ebuild b/dev-lang/ruby/ruby-2.4.5.ebuild
new file mode 100644 (file)
index 0000000..80efa36
--- /dev/null
@@ -0,0 +1,229 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib
+
+MY_P="${PN}-$(ver_cut 1-3)"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
+RUBYVERSION=${SLOT}.0
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="https://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.xz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl static-libs tk xemacs"
+
+RDEPEND="
+       berkdb? ( sys-libs/db:= )
+       gdbm? ( sys-libs/gdbm:= )
+       jemalloc? ( dev-libs/jemalloc )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl )
+       )
+       socks5? ( >=net-proxy/dante-1.1.13 )
+       tk? (
+               dev-lang/tcl:0=[threads]
+               dev-lang/tk:0=[threads]
+       )
+       dev-libs/libyaml
+       virtual/libffi:=
+       sys-libs/zlib
+       >=app-eselect/eselect-ruby-20161226
+       !<dev-ruby/rdoc-3.9.4
+       !<dev-ruby/rubygems-1.8.10-r1"
+
+DEPEND="${RDEPEND}"
+
+BUNDLED_GEMS="
+       >=dev-ruby/did_you_mean-1.1.0:2.4[ruby_targets_ruby24]
+       >=dev-ruby/minitest-5.10.1[ruby_targets_ruby24]
+       >=dev-ruby/net-telnet-0.1.1[ruby_targets_ruby24]
+       >=dev-ruby/power_assert-0.4.1[ruby_targets_ruby24]
+       >=dev-ruby/rake-12.0.0[ruby_targets_ruby24]
+       >=dev-ruby/test-unit-3.2.3[ruby_targets_ruby24]
+       >=dev-ruby/xmlrpc-0.2.1[ruby_targets_ruby24]
+"
+
+PDEPEND="
+       ${BUNDLED_GEMS}
+       virtual/rubygems[ruby_targets_ruby24]
+       >=dev-ruby/json-2.0.2[ruby_targets_ruby24]
+       rdoc? ( >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24] )
+       xemacs? ( app-xemacs/ruby-modes )"
+
+src_prepare() {
+       eapply "${FILESDIR}"/${SLOT}/{002,005,009}*.patch
+
+       einfo "Unbundling gems..."
+       cd "$S"
+       # Remove bundled gems that we will install via PDEPEND, bug
+       # 539700. Use explicit version numbers to ensure rm fails when they
+       # change so we can update dependencies accordingly.
+       rm -f gems/{did_you_mean-1.1.0,minitest-5.10.1,net-telnet-0.1.1,power_assert-0.4.1,rake-12.0.0,test-unit-3.2.3,xmlrpc-0.2.1}.gem || die
+
+       einfo "Removing bundled libraries..."
+       rm -fr ext/fiddle/libffi-3.2.1 || die
+
+       # Fix a hardcoded lib path in configure script
+       sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+               configure.in || die "sed failed"
+
+       eapply_user
+
+       eautoreconf
+}
+
+src_configure() {
+       local modules= myconf=
+
+       # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+       filter-flags -fomit-frame-pointer
+       # In many places aliasing rules are broken; play it safe
+       # as it's risky with newer compilers to leave it as it is.
+       append-flags -fno-strict-aliasing
+       # SuperH needs this
+       use sh && append-flags -mieee
+
+       # Socks support via dante
+       if use socks5 ; then
+               # Socks support can't be disabled as long as SOCKS_SERVER is
+               # set and socks library is present, so need to unset
+               # SOCKS_SERVER in that case.
+               unset SOCKS_SERVER
+       fi
+
+       # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+       if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+               append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+       fi
+
+       # ipv6 hack, bug 168939. Needs --enable-ipv6.
+       use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+
+       # Determine which modules *not* to build depending in the USE flags.
+       if ! use berkdb ; then
+               modules="${modules},dbm"
+       fi
+       if ! use gdbm ; then
+               modules="${modules},gdbm"
+       fi
+       if ! use ssl ; then
+               modules="${modules},openssl"
+       fi
+       if ! use tk ; then
+               modules="${modules},tk"
+       fi
+
+       # Provide an empty LIBPATHENV because we disable rpath but we do not
+       # need LD_LIBRARY_PATH by default since that breaks USE=multitarget
+       # #564272
+       INSTALL="${EPREFIX}/usr/bin/install -c" LIBPATHENV="" econf \
+               --program-suffix=${MY_SUFFIX} \
+               --with-soname=ruby${MY_SUFFIX} \
+               --docdir=${EPREFIX}/usr/share/doc/${P} \
+               --enable-shared \
+               --enable-pthread \
+               --disable-rpath \
+               --with-out-ext="${modules}" \
+               $(use_with jemalloc jemalloc) \
+               $(use_enable socks5 socks) \
+               $(use_enable doc install-doc) \
+               --enable-ipv6 \
+               $(use_enable static-libs static) \
+               $(use_enable static-libs install-static-library) \
+               $(use_with static-libs static-linked-ext) \
+               $(use_enable debug) \
+               ${myconf} \
+               --enable-option-checking=no \
+               || die "econf failed"
+}
+
+src_compile() {
+       emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+       emake -j1 V=1 test || die "make test failed"
+
+       elog "Ruby's make test has been run. Ruby also ships with a make check"
+       elog "that cannot be run until after ruby has been installed."
+       elog
+       if use rubytests; then
+               elog "You have enabled rubytests, so they will be installed to"
+               elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+               elog "than root, and you must place them into a writeable directory."
+               elog "Then call: "
+               elog
+               elog "ruby${MY_SUFFIX} -C /location/of/tests runner.rb"
+       else
+               elog "Enable the rubytests USE flag to install the make check tests"
+       fi
+}
+
+src_install() {
+       # Remove the remaining bundled gems. We do this late in the process
+       # since they are used during the build to e.g. create the
+       # documentation.
+       rm -rf ext/json || die
+
+       # Ruby is involved in the install process, we don't want interference here.
+       unset RUBYOPT
+
+       local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+
+       LD_LIBRARY_PATH="${S}:${ED}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+       RUBYLIB="${S}:${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
+       for d in $(find "${S}/ext" -type d) ; do
+               RUBYLIB="${RUBYLIB}:$d"
+       done
+       export LD_LIBRARY_PATH RUBYLIB
+
+       emake V=1 DESTDIR="${D}" install || die "make install failed"
+
+       # Remove installed rubygems and rdoc copy
+       rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
+       rm -rf "${ED}/usr/bin/"gem"${MY_SUFFIX}" || die "rm rdoc bins failed"
+       rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}"/rdoc* || die "rm rdoc failed"
+       rm -rf "${ED}/usr/bin/"{ri,rdoc}"${MY_SUFFIX}" || die "rm rdoc bins failed"
+
+       if use doc; then
+               make DESTDIR="${D}" install-doc || die "make install-doc failed"
+       fi
+
+       if use examples; then
+               insinto /usr/share/doc/${PF}
+               doins -r sample
+       fi
+
+       dodoc ChangeLog NEWS doc/NEWS* README* || die
+
+       if use rubytests; then
+               pushd test
+               insinto /usr/share/${PN}-${SLOT}/test
+               doins -r .
+               popd
+       fi
+}
+
+pkg_postinst() {
+       if [[ ! -n $(readlink "${EROOT}"usr/bin/ruby) ]] ; then
+               eselect ruby set ruby${MY_SUFFIX}
+       fi
+
+       elog
+       elog "To switch between available Ruby profiles, execute as root:"
+       elog "\teselect ruby set ruby(23|24|...)"
+       elog
+}
+
+pkg_postrm() {
+       eselect ruby cleanup
+}