media-sound/kmidimon: add patch fixing build failure with kde-base/kdelibs-4.14.11
authorMichael Palimaka <kensington@gentoo.org>
Sun, 30 Aug 2015 16:22:56 +0000 (02:22 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 30 Aug 2015 16:23:43 +0000 (02:23 +1000)
Gentoo-bug: 559180

Package-Manager: portage-2.2.20.1

media-sound/kmidimon/files/kmidimon-0.7.5-kdelibs-4.14.11.patch [new file with mode: 0644]
media-sound/kmidimon/kmidimon-0.7.5.ebuild

diff --git a/media-sound/kmidimon/files/kmidimon-0.7.5-kdelibs-4.14.11.patch b/media-sound/kmidimon/files/kmidimon-0.7.5-kdelibs-4.14.11.patch
new file mode 100644 (file)
index 0000000..833be96
--- /dev/null
@@ -0,0 +1,17 @@
+The uninstall target is created automatically by FindKDE4Internal. Due to
+cmake policy changes in kdelibs-4.14.11, this target name collision causes
+a build failure.
+
+https://bugs.gentoo.org/show_bug.cgi?id=559180
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -132,8 +132,6 @@
+     "${CMAKE_SOURCE_DIR}/cmake_admin/cmake_uninstall.cmake.in"
+     "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+     IMMEDIATE @ONLY)
+-ADD_CUSTOM_TARGET(uninstall
+-    "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+ ADD_CUSTOM_TARGET ( tarball
+     COMMAND mkdir -p kmidimon-${VERSION}
index 9a0f8a3769660673ea52fa72e665dbbbc6b65454..9e4cb991a58290df64386f4673d54715a7d99b4e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -24,6 +24,7 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 
 DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=( "${FILESDIR}/${P}-kdelibs-4.14.11.patch" )
 
 src_configure() {
        local mycmakeargs=(