kde-frameworks/kio: Drop 5.70.0-r1
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 16 May 2020 09:06:26 +0000 (11:06 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 16 May 2020 09:08:04 +0000 (11:08 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-frameworks/kio/Manifest
kde-frameworks/kio/files/kio-5.70.0-fix-run-in-terminal.patch [deleted file]
kde-frameworks/kio/kio-5.70.0-r1.ebuild [deleted file]

index c9a070ae5bc2eacd7595386ea94805674fa51173..ee4062252944e5676f6606ebd065fb49d7ef4b06 100644 (file)
@@ -1,3 +1,2 @@
 DIST kio-5.67.0.tar.xz 3223032 BLAKE2B 297ebb3f12282951e85edc4eb9869ff3b6fd9536aa312f32ab7403337bb13a142c37edc03ae2295fe55cc935d6952c70e0efda95a3fcc280709e6ef33c30ea04 SHA512 baf1e6abc6ae1ffa4010245a79cb676787217d365fb033f620a9da293565ec267186afaac08791104cead3ce5c87d3a76ec89b796355361b326b16f044691d72
-DIST kio-5.70.0.tar.xz 3200704 BLAKE2B 23540865ab0310fb3564cfcc445602aab46c8cdbc3b1d40e9428e13a46f9e3795a1fca853028226cb9e3313ef3d22a5347a9cfc9b058e1959bf4dbf861b0792f SHA512 80e8e8bcd49c09228c9a439f97aecca784880b852eeb82c84ec44868de44d2b0c5a63a4d220e6c2f2c264b7e87fe0d5b639f652b1f50c9fe1b1b941b366d929a
 DIST kio-5.70.1.tar.xz 3200752 BLAKE2B cc56ee412cb647c8921a36c3e47747640d5574444630f70887401c69ca1a367205adf4d7cd45b721abd103efcb1265c956654fce2dfc5b3fe6241413c51f1b88 SHA512 12287f330e8e7b9ac9c0ff24c1f8f980fbd338ce3f341d8005d6dc6e3acdf96da07adeea693b3361909819d8814192503e8d2c93ca9b9958d985f0d09f202661
diff --git a/kde-frameworks/kio/files/kio-5.70.0-fix-run-in-terminal.patch b/kde-frameworks/kio/files/kio-5.70.0-fix-run-in-terminal.patch
deleted file mode 100644 (file)
index 4b9b8bf..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-From 6452a34cf01d03d3167b38bc28a2fe8e13569021 Mon Sep 17 00:00:00 2001
-From: Jonathan Marten <jjm@keelhaul.me.uk>
-Date: Thu, 14 May 2020 19:17:54 +0100
-Subject: Fix service file specifying 'Run in terminal' giving an error code
- 100
-
-Happens because KIO::DesktopExecParser::resultingArguments() prepends
-the terminal application to the command line.  If this is a relative path,
-as it is most likely to be (and will be in the default 'konsole' case),
-the "realExecutable" check in KProcessRunner::KProcessRunner() is triggered
-and the job aborts with an error.
-
-Expand the specified terminal executable into a full path in resultingArguments(),
-and return an error immediately if it cannot be found.  This full terminal path
-is not relative for the KProcessRunner::KProcessRunner() check and does not fail.
-
-Check that resultingArguments() is not empty (an error return) before accessing
-the first word of the command, so that it does not assert if the list is empty.
-Also only call resultingArguments() once.
-
-BUG: 421374
-FIXED-IN: 5.71
-
-Differential Revision: https://phabricator.kde.org/D29738
----
- src/core/desktopexecparser.cpp | 10 +++++++++-
- src/gui/kprocessrunner.cpp     | 17 +++++++++--------
- 2 files changed, 18 insertions(+), 9 deletions(-)
-
-diff --git a/src/core/desktopexecparser.cpp b/src/core/desktopexecparser.cpp
-index a3b5219..fcf83d9 100644
---- a/src/core/desktopexecparser.cpp
-+++ b/src/core/desktopexecparser.cpp
-@@ -421,7 +421,15 @@ QStringList KIO::DesktopExecParser::resultingArguments() const
-     if (d->service.terminal()) {
-         KConfigGroup cg(KSharedConfig::openConfig(), "General");
-         QString terminal = cg.readPathEntry("TerminalApplication", QStringLiteral("konsole"));
--        if (terminal == QLatin1String("konsole")) {
-+        const bool isKonsole = (terminal == QLatin1String("konsole"));
-+
-+        QString terminalPath = QStandardPaths::findExecutable(terminal);
-+        if (terminalPath.isEmpty()) {
-+            qCWarning(KIO_CORE) << "Terminal" << terminal << "not found, service" << d->service.name();
-+            return QStringList();
-+        }
-+        terminal = terminalPath;
-+        if (isKonsole) {
-             if (!d->service.workingDirectory().isEmpty()) {
-                 terminal += QLatin1String(" --workdir ") + KShell::quoteArg(d->service.workingDirectory());
-             }
-diff --git a/src/gui/kprocessrunner.cpp b/src/gui/kprocessrunner.cpp
-index a4701a7..cc57b54 100644
---- a/src/gui/kprocessrunner.cpp
-+++ b/src/gui/kprocessrunner.cpp
-@@ -88,9 +88,17 @@ KProcessRunner::KProcessRunner(const KService::Ptr &service, const QList<QUrl> &
-         emitDelayedError(i18n("The desktop entry file\n%1\nis not valid.", service->entryPath()));
-         return;
-     }
-+
-     KIO::DesktopExecParser execParser(*service, urls);
-+    execParser.setUrlsAreTempFiles(flags & KIO::ApplicationLauncherJob::DeleteTemporaryFiles);
-+    execParser.setSuggestedFileName(suggestedFileName);
-+    const QStringList args = execParser.resultingArguments();
-+    if (args.isEmpty()) {
-+        emitDelayedError(i18n("Error processing Exec field in %1", service->entryPath()));
-+        return;
-+    }
--    const QString realExecutable = execParser.resultingArguments().at(0);
-+    const QString realExecutable = args.at(0);
-     // realExecutable is a full path if DesktopExecParser was able to locate it. Otherwise it's still relative, which is a bad sign.
-     if (QDir::isRelativePath(realExecutable) || !QFileInfo(realExecutable).isExecutable()) {
-         // Does it really not exist, or is it non-executable? (bug #415567)
-@@ -103,13 +111,6 @@ KProcessRunner::KProcessRunner(const KService::Ptr &service, const QList<QUrl> &
-         return;
-     }
--    execParser.setUrlsAreTempFiles(flags & KIO::ApplicationLauncherJob::DeleteTemporaryFiles);
--    execParser.setSuggestedFileName(suggestedFileName);
--    const QStringList args = execParser.resultingArguments();
--    if (args.isEmpty()) {
--        emitDelayedError(i18n("Error processing Exec field in %1", service->entryPath()));
--        return;
--    }
-     //qDebug() << "KProcess args=" << args;
-     *m_process << args;
--- 
-cgit v1.1
diff --git a/kde-frameworks/kio/kio-5.70.0-r1.ebuild b/kde-frameworks/kio/kio-5.70.0-r1.ebuild
deleted file mode 100644 (file)
index c95390b..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_DESIGNERPLUGIN="true"
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.12.3
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org xdg-utils
-
-DESCRIPTION="Framework providing transparent file and data management"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="acl +handbook kerberos +kwallet X"
-
-# drop qtnetwork subslot operator when QT_MINIMAL >= 5.15.0
-RDEPEND="
-       dev-libs/libxml2
-       dev-libs/libxslt
-       >=dev-qt/qtdbus-${QTMIN}:5
-       >=dev-qt/qtdeclarative-${QTMIN}:5
-       >=dev-qt/qtgui-${QTMIN}:5
-       >=dev-qt/qtnetwork-${QTMIN}:5=[ssl]
-       >=dev-qt/qtwidgets-${QTMIN}:5
-       >=dev-qt/qtxml-${QTMIN}:5
-       =kde-frameworks/kauth-${PVCUT}*:5
-       =kde-frameworks/karchive-${PVCUT}*:5
-       =kde-frameworks/kbookmarks-${PVCUT}*:5
-       =kde-frameworks/kcodecs-${PVCUT}*:5
-       =kde-frameworks/kcompletion-${PVCUT}*:5
-       =kde-frameworks/kconfig-${PVCUT}*:5
-       =kde-frameworks/kconfigwidgets-${PVCUT}*:5
-       =kde-frameworks/kcoreaddons-${PVCUT}*:5
-       =kde-frameworks/kcrash-${PVCUT}*:5
-       =kde-frameworks/kdbusaddons-${PVCUT}*:5
-       =kde-frameworks/ki18n-${PVCUT}*:5
-       =kde-frameworks/kiconthemes-${PVCUT}*:5
-       =kde-frameworks/kitemviews-${PVCUT}*:5
-       =kde-frameworks/kjobwidgets-${PVCUT}*:5
-       =kde-frameworks/knotifications-${PVCUT}*:5
-       =kde-frameworks/kservice-${PVCUT}*:5
-       =kde-frameworks/ktextwidgets-${PVCUT}*:5
-       =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
-       =kde-frameworks/kwindowsystem-${PVCUT}*:5
-       =kde-frameworks/kxmlgui-${PVCUT}*:5
-       =kde-frameworks/solid-${PVCUT}*:5
-       acl? (
-               sys-apps/attr
-               virtual/acl
-       )
-       handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
-       kerberos? ( virtual/krb5 )
-       kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
-       X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
-"
-DEPEND="${RDEPEND}
-       >=dev-qt/qtconcurrent-${QTMIN}:5
-       test? ( sys-libs/zlib )
-       X? (
-               x11-base/xorg-proto
-               x11-libs/libX11
-               x11-libs/libXrender
-       )
-"
-PDEPEND="
-       >=kde-frameworks/kded-${PVCUT}:5
-"
-
-# tests hang
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-run-in-terminal.patch )
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake_use_find_package acl ACL)
-               $(cmake_use_find_package handbook KF5DocTools)
-               $(cmake_use_find_package kerberos GSSAPI)
-               $(cmake_use_find_package kwallet KF5Wallet)
-               $(cmake_use_find_package X X11)
-       )
-
-       ecm_src_configure
-}
-
-pkg_postinst() {
-       ecm_pkg_postinst
-       xdg_desktop_database_update
-}
-
-pkg_postrm() {
-       ecm_pkg_postrm
-       xdg_desktop_database_update
-}