perl-core/Math-BigInt,virtual/perl-Math-BigInt: Bump to version 1.999.806 (masked)
authorKent Fredric <kentnl@gentoo.org>
Sun, 19 Mar 2017 04:52:03 +0000 (17:52 +1300)
committerKent Fredric <kentnl@gentoo.org>
Sun, 19 Mar 2017 04:52:52 +0000 (17:52 +1300)
Upstream:
- bzero, bone, binf, bnan no longer check object needs modification
  when used as constructors
- Improve bgcd and blcm
- Use EUMM instead of Module::Install
- Add as_bytes and from_bytes functions to BigInt
- Fix implementation of from_{hex,oct,bin}

Package-Manager: Portage-2.3.4, Repoman-2.3.2

perl-core/Math-BigInt/Manifest
perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild [new file with mode: 0644]
virtual/perl-Math-BigInt/perl-Math-BigInt-1.999.806.ebuild [new file with mode: 0644]

index 6572d1045c6c7075104eb26c78aff9a6a8ff5633..a089014eb136402ebedd19ec8093aa4dde49cf8f 100644 (file)
@@ -2,3 +2,4 @@ DIST Math-BigInt-1.9993.tar.gz 215143 SHA256 d937c0d1afbb3ddd9b666177faf56471b6c
 DIST Math-BigInt-1.999710.tar.gz 225641 SHA256 879514c3dda33b6f05816569ca1a0f31b650df87660ecf80afbd60e396118610 SHA512 a5f938f5f2c61fd1b4c5c01caa99104aea2a009c8f6e089b465d52948a631cd7cb2df2c54917d9e4bd0bc34281c3a8aa865eb3bf7e6e84f15cff1eb79ccf358d WHIRLPOOL 73e26895de11824008b41e39968903c9a7b888a5b199e64f235e2b86e2360df8b095e6a9f2e29c3c29a385025e33cbbd88dc3f84220c6fd89add49596a1814ee
 DIST Math-BigInt-1.999715.tar.gz 252193 SHA256 cfae5c43c4cabe92a940f13e4a23515be4e0dbe72cba8d448a3e96f869794987 SHA512 85d5e168e41f53a37cfcdbef3a2b9a998be7344e828675cda5e3d9db320d4d617555aa9611ecabd6a13974d3a3eee8ec624e9f839bc6ac7a3abecc6a67305bc7 WHIRLPOOL a0a293278391031948e0e5914f239bc6fb92297eefa4fcec92c540ebdfb796f5f60fe22c0f3dde76f9779a9a3b05c74d3da153d7b83a273b05053f308ac49fd5
 DIST Math-BigInt-1.999801.tar.gz 2761631 SHA256 41deb23d453f5a376759fff155e4947988a6b6713a4164f21aedac8238089e57 SHA512 fd0dd80a8b495ecbfc61ca089793d66b9e9c9edde6dccbd25a18725bd8ee097a0c8e58f66d340e4a9e9ccce84f9d1f70f755eb65c2f4ecc8ba7cba83692a0cc1 WHIRLPOOL e860edb664a0b2fbdd7040694213d6b3606d488a26c7913cee0efa9945937849cbd47d73244fd0c35a4579fed6da721943408e893e4ea67dd20a4d352320af2e
+DIST Math-BigInt-1.999806.tar.gz 2814121 SHA256 9b62b2fcfeed5ef42d375778e4ec3b469cab0002b5dc247906dc99f5786fa1fc SHA512 2c496450ecc64acb7635ed2bf3b1bb0faef77aee56aee391341ca180e63037c4bc9fee6e8ae23f1db610df56a83e703a602ed37a83b35f294f7536642d897e9f WHIRLPOOL 23947f920a524476c898b3cffd8851809876a8938c8d655742070986d6c19eaf32c810769ed849538077dd16d55cf6a8fceca1909da11f7dbe052344e5e0ba6c
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
new file mode 100644 (file)
index 0000000..9d2b14f
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999806
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+       >=virtual/perl-Math-Complex-1.390.0
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+PDEPEND="
+       >=virtual/perl-Math-BigInt-FastCalc-0.270.0
+       >=virtual/perl-bignum-0.220.0
+       >=virtual/perl-Math-BigRat-0.260.200
+"
+# where does this come from?
+
+src_test() {
+       perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+       perl-module_src_test
+}
diff --git a/virtual/perl-Math-BigInt/perl-Math-BigInt-1.999.806.ebuild b/virtual/perl-Math-BigInt/perl-Math-BigInt-1.999.806.ebuild
new file mode 100644 (file)
index 0000000..94980ca
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for ${PN#perl-}"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+       ~perl-core/${PN#perl-}-${PV}
+       dev-lang/perl:=
+"