dev-python/nuitka: bump to version 0.6.7
authorOz N Tiram <oz.tiram@gmail.com>
Sun, 19 Apr 2020 19:46:50 +0000 (21:46 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 21 Apr 2020 12:44:46 +0000 (15:44 +0300)
 This version also adds man pages and other missing documentation.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Oz Tiram <oz.tiram@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15417
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/nuitka/Manifest
dev-python/nuitka/nuitka-0.6.7.ebuild [new file with mode: 0644]

index 77ae4b1a066e8fcf285685d9f71ab3c3a6e882f1..753d5c9b0b4eec15f40740088172485952158dc2 100644 (file)
@@ -1 +1,2 @@
 DIST Nuitka-0.6.6.tar.gz 2276002 BLAKE2B 74ada1032d5eef3068e6c0fbd088437014de8752b71ce98b90bb868bb7241efe301d4fa1ef661f00f54730ca3d27470cc6c804bc2b394085349ad9a1aed0feb4 SHA512 82752105fc5b5d5d09d460ba25a6424420ff055ea841a32c6e32ec9099870ceefe06dcadab347fe689cec94f4d8891a4125910f7cff504a8aa736139b29c2a8b
+DIST Nuitka-0.6.7.tar.gz 2284868 BLAKE2B 91c2e5362697d8c14f0627d757c70922aff3ccc2c9eb359f6b303e9ae7580d594106328b9fe644e8f668018aae496e50041948bdfbf59c27fe1ce0e50eb90177 SHA512 9f3dbfe67f2618a5363aa47974fe0199428a4798e79ebfcf78f15365048a6c676b5b2c9d5569adcd264389c66f643b3190647dc17acb76e59b9b95ee6762f5a2
diff --git a/dev-python/nuitka/nuitka-0.6.7.ebuild b/dev-python/nuitka/nuitka-0.6.7.ebuild
new file mode 100644 (file)
index 0000000..49bb2c5
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils python-utils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+
+RDEPEND="${BDEPEND}
+       dev-python/appdirs[${PYTHON_USEDEP}]"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+S="${WORKDIR}/${P^}"
+
+python_install() {
+       distutils-r1_python_install
+       python_optimize
+       doman doc/nuitka.1
+       doman doc/nuitka3.1
+       doman doc/nuitka3-run.1
+       doman doc/nuitka-run.1
+}
+
+pkg_postinst() {
+       optfeature "support for stand-alone executables" app-admin/chrpath
+}