media-video/cclive: fix building w/gcc-5 #548310
authorMike Frysinger <vapier@gentoo.org>
Mon, 7 Sep 2015 03:11:50 +0000 (23:11 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 7 Sep 2015 03:12:16 +0000 (23:12 -0400)
media-video/cclive/cclive-0.9.3-r1.ebuild
media-video/cclive/files/cclive-0.9.3-boost-ver-check.patch [new file with mode: 0644]

index e911be3df68fe3d31b824955cb583bc0ba559b42..8566a4e9e4d72e1c2753f92e6909973cfb02535d 100644 (file)
@@ -26,6 +26,7 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-iostream.patch #527658
+       epatch "${FILESDIR}"/${P}-boost-ver-check.patch #548310
 }
 
 src_configure() {
diff --git a/media-video/cclive/files/cclive-0.9.3-boost-ver-check.patch b/media-video/cclive/files/cclive-0.9.3-boost-ver-check.patch
new file mode 100644 (file)
index 0000000..23e69dd
--- /dev/null
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/548310
+
+apply boost.m4 updates to fix building w/gcc-5
+
+--- a/configure
++++ b/configure
+@@ -17481,8 +17481,10 @@
+ boost-lib-version = BOOST_LIB_VERSION
+ _ACEOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
++  grep -v '#' |
+   tr -d '\r' |
+-  $SED -n -e "/^boost-lib-version = /{s///;s/\"//g;p;q;}" >conftest.i 2>&1; then :
++  tr -s '\n' ' ' |
++  $SED -n -e "/^boost-lib-version = /{s///;s/[\" ]//g;p;q;}" >conftest.i 2>&1; then :
+   boost_cv_lib_version=`cat conftest.i`
+ fi
+ rm -rf conftest*