dev-python/pyformance: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 19 Aug 2018 21:44:04 +0000 (23:44 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 21 Aug 2018 08:28:55 +0000 (10:28 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/pyformance/Manifest
dev-python/pyformance/pyformance-0.4.ebuild [new file with mode: 0644]

index eb2b19ce95c8b7dae1687a94dcabb65ee55b9ca3..6960c533444f3dec668c0f65974a66c577807672 100644 (file)
@@ -1 +1,2 @@
 DIST pyformance-0.3.4.tar.gz 19394 BLAKE2B 4bd141df5b3264ae8abb5b5314fcba93aeeab960e4d1d70631a3d5ac072f94a2da48b480f74c446124fb9fbd54a8ffad9c75b2352509aaf991025a02bf736648 SHA512 5dbc83da62bf66767eaaf316824cf5683488d8ee594b72baee327c4ef594f84b5aed07654da483aff29bee98605e5265425be88c165a4bb06e7bdddbbf28e440
+DIST pyformance-0.4.tar.gz 20683 BLAKE2B d818832b7ff43a7e1db888bdb7dc333a532c7d3365dd472f9dbb3300f676cd3cc8f82f8d1c444aa277404ff8e72843eca35e3905542700ea37b1dad3e05c8b4c SHA512 a03324977b40f5097ae4608dd7c36bdbd2a20b261c9d3e32d1be19e5fca50e17fcc24df781b6c3ab60314534368c5e9cf08bc3863d4d2d7ecc59f9af26f8d20e
diff --git a/dev-python/pyformance/pyformance-0.4.ebuild b/dev-python/pyformance/pyformance-0.4.ebuild
new file mode 100644 (file)
index 0000000..67ffb16
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}]
+                       dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare() {
+       sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/"
+}
+
+python_test() {
+       py.test || die
+}