net-mail/mailutils: [QA] Multiple fixes
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 09:52:57 +0000 (11:52 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 09:52:57 +0000 (11:52 +0200)
* Use relative symlinks for better chroot
* Use proper || die
* Honour USE="-split-usr" systems properly

Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
net-mail/mailutils/mailutils-3.4-r3.ebuild
net-mail/mailutils/mailutils-3.7.ebuild

index ab5c356f37f0dac68304bed13834a6ad510ee350..41d2ec0c56f1c6dc10d2bae26df1ece2e2eebbfa 100644 (file)
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 ~sparc x86 ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="berkdb bidi +clients emacs gdbm sasl guile ipv6 kerberos kyotocabinet \
-       ldap mysql nls pam postgres python servers ssl static-libs +threads tcpd \
+       ldap mysql nls pam postgres python servers split-usr ssl static-libs +threads tcpd \
        tokyocabinet"
 
 RDEPEND="!mail-client/nmh
@@ -105,7 +105,7 @@ src_configure() {
 }
 
 src_install() {
-       emake DESTDIR="${D}" install
+       default
 
        insinto /etc
        # bug 613112
@@ -127,10 +127,12 @@ src_install() {
                newinitd "${FILESDIR}"/comsatd.initd comsatd
        fi
 
-       dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
-
        # compatibility link
-       use clients && dosym /usr/bin/mail /bin/mail
+       if use clients && use split-usr; then
+               dosym ../usr/bin/mail /bin/mail
+       fi
 
-       use static-libs || find "${D}" -name "*.la" -delete
+       if ! use static-libs; then
+               find "${D}" -name "*.la" -delete || die
+       fi
 }
index 76cd4bd9c8111671e2c7473a3b72da562a55b513..493ba4d9f40c89ddc50470fd538f4df720423889 100644 (file)
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="berkdb bidi +clients emacs gdbm sasl guile ipv6 kerberos kyotocabinet \
-       ldap mysql nls pam postgres python servers ssl static-libs +threads tcpd \
+       ldap mysql nls pam postgres python servers split-usr ssl static-libs +threads tcpd \
        tokyocabinet"
 
 RDEPEND="!mail-client/nmh
@@ -105,7 +105,6 @@ src_configure() {
 
 src_install() {
        default
-       emake DESTDIR="${D}" install
 
        insinto /etc
        # bug 613112
@@ -128,7 +127,11 @@ src_install() {
        fi
 
        # compatibility link
-       use clients && dosym /usr/bin/mail /bin/mail
+       if use clients && use split-usr; then
+               dosym ../usr/bin/mail /bin/mail
+       fi
 
-       use static-libs || find "${D}" -name "*.la" -delete
+       if ! use static-libs; then
+               find "${D}" -name "*.la" -delete || die
+       fi
 }