media-gfx/geeqie: use xdg eclass
authorBernard Cafarelli <voyageur@gentoo.org>
Tue, 10 Dec 2019 21:27:09 +0000 (22:27 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Tue, 10 Dec 2019 21:34:55 +0000 (22:34 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
media-gfx/geeqie/geeqie-1.5.1.ebuild
media-gfx/geeqie/geeqie-9999.ebuild

index 2d57b0dbebfe39feaa11010dcbbe954533019611..88c65fbe11e3b6467acab30bb450e617d9c02b6d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit autotools xdg-utils
+inherit autotools xdg
 
 DESCRIPTION="A lightweight GTK image viewer forked from GQview"
 HOMEPAGE="http://www.geeqie.org"
@@ -83,13 +83,9 @@ src_install() {
 }
 
 pkg_postinst() {
-       xdg_desktop_database_update
+       xdg_pkg_postinst
 
        elog "Some plugins may require additional packages"
        elog "- Image rotate plugin: media-gfx/fbida (JPEG), media-gfx/imagemagick (TIFF/PNG)"
        elog "- RAW images plugin: media-gfx/ufraw"
 }
-
-pkg_postrm() {
-       xdg_desktop_database_update
-}
index e7ca05a8bf037dc74597457b868133c03fcacd21..3f25e162490a300aaec5c60f45f2b1521dc6b5c1 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit autotools git-r3 xdg-utils
+inherit autotools git-r3 xdg
 
 DESCRIPTION="A lightweight GTK image viewer forked from GQview"
 HOMEPAGE="http://www.geeqie.org"
@@ -84,13 +84,9 @@ src_install() {
 }
 
 pkg_postinst() {
-       xdg_desktop_database_update
+       xdg_pkg_postinst
 
        elog "Some plugins may require additional packages"
        elog "- Image rotate plugin: media-gfx/fbida (JPEG), media-gfx/imagemagick (TIFF/PNG)"
        elog "- RAW images plugin: media-gfx/ufraw"
 }
-
-pkg_postrm() {
-       xdg_desktop_database_update
-}