dev-python/autopep8: git-2->git-r3
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 27 Apr 2018 17:55:26 +0000 (12:55 -0500)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Apr 2018 10:29:23 +0000 (12:29 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

dev-python/autopep8/autopep8-1.3.2.ebuild
dev-python/autopep8/autopep8-1.3.3.ebuild
dev-python/autopep8/autopep8-9999.ebuild

index d26545d20f216103bf22925ec54358906798d09f..704659d6b8805875a40e212d1aa639f0d35239a8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,11 +10,16 @@ inherit distutils-r1
 
 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
 HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 
 RDEPEND="
index 48c985d0e5cd2f51a8f05e14129e2317041ccd96..86abf7bd303fd4b6101c45ae7a678dd04c6f60e9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,11 +10,16 @@ inherit distutils-r1
 
 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
 HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 
 RDEPEND="
index 9b6187b0add60bcf100591ed2ed2056a0f8fa7d8..1ebdd95ae114e0bf10a4a4cc7a0cedbfd7198924 100644 (file)
@@ -1,20 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
 PYTHON_REQ_USE="threads(+)"
 
-inherit distutils-r1 git-2
+inherit distutils-r1
 
 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
 HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS=""
 IUSE="test"
 
 RDEPEND="