dev-ruby/tty-command: initial import of 0.8.2
authorHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 06:05:33 +0000 (08:05 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 09:55:36 +0000 (11:55 +0200)
New dependency for www-apps/nanoc

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/tty-command/Manifest [new file with mode: 0644]
dev-ruby/tty-command/metadata.xml [new file with mode: 0644]
dev-ruby/tty-command/tty-command-0.8.2.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
new file mode 100644 (file)
index 0000000..b8f21fb
--- /dev/null
@@ -0,0 +1 @@
+DIST tty-command-0.8.2.tar.gz 30126 BLAKE2B 858b9c60380859bd984295e00638ba93416c62acbe4e5c1d0e33b411862d729c129f00dda236f4ca9943962859a35c9fe1fa2431327fb2e3170366412f8d83e3 SHA512 151af5fe0cf241b4e8004560d04fe967d8fe1d24cf311d64c4fab46d1c11b1fe27849f3925f13d3a73b7b86a55aabacd3e4bbffa9a96c34669c93b29756fe88e
diff --git a/dev-ruby/tty-command/metadata.xml b/dev-ruby/tty-command/metadata.xml
new file mode 100644 (file)
index 0000000..9be0b27
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ruby@gentoo.org</email>
+               <name>Gentoo Ruby Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">piotrmurach/tty-command</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-command/tty-command-0.8.2.ebuild b/dev-ruby/tty-command/tty-command-0.8.2.ebuild
new file mode 100644 (file)
index 0000000..3bb1808
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/pastel-0.7*"
+
+all_ruby_prepare() {
+       echo '-rspec_helper' > .rspec || die
+}