app-misc/todo: add patch to fix bash completion.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 8 Apr 2017 21:56:11 +0000 (23:56 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 8 Apr 2017 21:56:11 +0000 (23:56 +0200)
Courtesy of Ferenc Erki <erkiferenc@gmail.com>.

Gentoo-Bug: https://bugs.gentoo.org/614400

Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-misc/todo/files/todo-2.10-fix-bash-completion.patch [new file with mode: 0644]
app-misc/todo/todo-2.10-r1.ebuild [new file with mode: 0644]

diff --git a/app-misc/todo/files/todo-2.10-fix-bash-completion.patch b/app-misc/todo/files/todo-2.10-fix-bash-completion.patch
new file mode 100644 (file)
index 0000000..7e6de2f
--- /dev/null
@@ -0,0 +1,12 @@
+--- ./todo_completion  2017-04-08 15:18:23.102736966 +0200
++++ ./todo_completion  2017-04-08 15:18:56.839725605 +0200
+@@ -85,6 +85,9 @@
+ }
+ complete -F _todo todo.sh
++# Gentoo bug 614400
++complete -F _todo todotxt
++
+ # If you define an alias (e.g. "t") to todo.sh, you need to explicitly enable
+ # completion for it, too:
+ #complete -F _todo t
diff --git a/app-misc/todo/todo-2.10-r1.ebuild b/app-misc/todo/todo-2.10-r1.ebuild
new file mode 100644 (file)
index 0000000..5fa2cd2
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com/"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+PATCHES=( "${FILESDIR}/${P}-fix-bash-completion.patch" )
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+src_test() {
+       make test || die "tests failed"
+}
+
+src_install() {
+       dobin "${PN}.sh"
+       dosym "/usr/bin/${PN}.sh" "/usr/bin/${PN}txt"
+       newbashcomp "${PN}_completion" "${PN}.sh"
+       bashcomp_alias "${PN}.sh" "${PN}txt"
+       einstalldocs
+}