Added initial support for quake3-teamarena.
authorChris Gianelloni <wolf31o2@gentoo.org>
Mon, 27 Mar 2006 18:43:12 +0000 (18:43 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Mon, 27 Mar 2006 18:43:12 +0000 (18:43 +0000)
Package-Manager: portage-2.1_pre6-r6

games-fps/quake3-bin/ChangeLog
games-fps/quake3-bin/files/digest-quake3-bin-1.32b-r5 [new file with mode: 0644]
games-fps/quake3-bin/quake3-bin-1.31.ebuild
games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
games-fps/quake3-bin/quake3-bin-1.32b-r5.ebuild [new file with mode: 0644]
games-fps/quake3/ChangeLog
games-fps/quake3/quake3-1.34_alpha632.ebuild
games-fps/quake3/quake3-9999.ebuild

index 389bf5089a2990560bf6caebad7f87e80a89ed76..17c169b68a2733363893edc47ec0f999dfa12734 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for games-fps/quake3-bin
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/ChangeLog,v 1.9 2006/03/22 21:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/ChangeLog,v 1.10 2006/03/27 18:43:12 wolf31o2 Exp $
+
+*quake3-bin-1.32b-r5 (27 Mar 2006)
+
+  27 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  quake3-bin-1.31.ebuild, quake3-bin-1.32b-r4.ebuild,
+  +quake3-bin-1.32b-r5.ebuild:
+  Added initial support for quake3-teamarena.
 
   22 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
   quake3-bin-1.31.ebuild, quake3-bin-1.32b-r4.ebuild:
diff --git a/games-fps/quake3-bin/files/digest-quake3-bin-1.32b-r5 b/games-fps/quake3-bin/files/digest-quake3-bin-1.32b-r5
new file mode 100644 (file)
index 0000000..91e5b5d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c71fdddccb20e8fc393d846e9c61d685 linuxq3apoint-1.32b-3.x86.run 30923961
+RMD160 eb63177fc0a30cda4976d8b68e065efb6dc41e50 linuxq3apoint-1.32b-3.x86.run 30923961
+SHA256 c36132c5556b35e01950f1e9c646235033a5130f87ad776ba2bc7becf4f4f186 linuxq3apoint-1.32b-3.x86.run 30923961
index 90b24f5f6a4fae91ba8f38fba103c00bdca436d8..187f9544a8e2c5ae3caff921a99b8e4ac791c990 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.31.ebuild,v 1.5 2006/03/22 21:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.31.ebuild,v 1.6 2006/03/27 18:43:12 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -11,7 +11,7 @@ SRC_URI="mirror://idsoftware/quake3/linux/linuxq3apoint-${PV}.x86.run"
 LICENSE="Q3AEULA"
 SLOT="0"
 KEYWORDS="-* amd64 x86"
-IUSE="cdinstall dedicated opengl"
+IUSE="dedicated opengl"
 RESTRICT="nostrip"
 
 RDEPEND="sys-libs/glibc
@@ -31,24 +31,16 @@ RDEPEND="sys-libs/glibc
                app-emulation/emul-linux-x86-baselibs
                opengl? (
                        app-emulation/emul-linux-x86-xlibs
-                       || (
-                               >=media-video/nvidia-glx-1.0.6629-r3
-                               >=x11-drivers/ati-drivers-8.8.25-r1 ) ) )
-       games-fps/quake3-data"
+                       || ( >=media-video/nvidia-glx-1.0.6629-r3
+                       >=x11-drivers/ati-drivers-8.8.25-r1 ) ) )"
 
 S=${WORKDIR}
-
-GAMES_CHECK_LICENSE="yes"
 dir=${GAMES_PREFIX_OPT}/quake3
 Ddir=${D}/${dir}
 
 pkg_setup() {
+       check_license Q3AEULA
        games_pkg_setup
-       if use cdinstall
-       then
-               built_with_use games-fps/quake3-data cdinstall \
-                       || die "You must install quake3-data with USE=cdinstall to get the required data."
-       fi
 }
 
 src_unpack() {
@@ -56,65 +48,41 @@ src_unpack() {
 }
 
 src_install() {
-       if use cdinstall ; then
-               dodir ${dir}/{baseq3,missionpack}
-               for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
-                       dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
-               done
-               dosym ${GAMES_DATADIR}/quake3/pak0.pk3 ${dir}/baseq3/pak0.pk3
-               dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
-                       ${dir}/missionpack/pak0.pk3
-       else
-               insinto ${dir}/baseq3
-               doins baseq3/*.pk3 || die "ins baseq3"
-               insinto ${dir}/missionpack
-               doins missionpack/*.pk3 || die "ins missionpack"
-       fi
-
-       insinto ${dir}
-       doins -r Docs pb || die "ins docs/pb"
+       insinto ${dir}/baseq3
+       doins baseq3/*.pk3
+       mv Help ${Ddir}
+       insinto ${dir}/missionpack
+       doins missionpack/*.pk3
 
        exeinto ${dir}
        insinto ${dir}
-       doexe bin/Linux/x86/quake3.x86 || die "doexe"
+       doexe bin/x86/{quake3.x86,q3ded} || die "doexe"
        doins quake3.xpm README* Q3A_EULA.txt
        games_make_wrapper quake3-bin ./quake3.x86 "${dir}" "${dir}"
-       if use dedicated
-       then
-               doexe bin/Linux/x86/q3ded || die "doexe q3ded"
-               games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
-               newinitd "${FILESDIR}"/q3ded.rc q3ded
-               newconfd "${FILESDIR}"/q3ded.conf.d q3ded
-       fi
-       newicon quake3.xpm quake3-bin.xpm
+       games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
+
+       newinitd "${FILESDIR}"/q3ded.rc q3ded
+       newconfd "${FILESDIR}"/q3ded.conf.d q3ded
+       doicon quake3.xpm
 
        prepgamesdirs
-       make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
+       make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3.xpm
 }
 
 pkg_postinst() {
        games_pkg_postinst
        echo
-       ewarn "There are two possible security bugs in this package, both causing a"
-       ewarn "denial of service. One affects the game when running a server, the"
-       ewarn "other when running as a client."
-       ewarn "For more information, please see bug #82149."
-       if ! use cdinstall ; then
-               echo
-               einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
-               einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
-       fi
+       ewarn "There are two possible security bugs in this package, both causing a     denial"
+       ewarn "of service.  One affects the game when running a server, the other when running"
+       ewarn "as a client.  For more information, see bug #82149."
+       echo
+       einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
+       einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
+       echo
        if use dedicated; then
-               echo
                einfo "To start a dedicated server, run"
-               einfo "  /etc/init.d/q3ded start"
+               einfo "\t/etc/init.d/q3ded start"
                echo
                einfo "The dedicated server is started under the ${GAMES_USER_DED} user account."
        fi
-
-       # IA32 Emulation required for amd64
-       if use amd64 ; then
-               echo
-               ewarn "NOTE: IA32 Emulation must be compiled into your kernel for Quake3 to run."
-       fi
 }
index 5daf7c192b295b9baef0f94bcd44d4fbd7bfd57d..7100a8ec4fca074276874a8be3be2826a69be5e4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.6 2006/03/22 21:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.7 2006/03/27 18:43:12 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -61,7 +61,7 @@ src_install() {
                for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
                        dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
                done
-               dosym ${GAMES_DATADIR}/quake3/pak0.pk3 ${dir}/baseq3/pak0.pk3
+               dosym ${GAMES_DATADIR}/quake3/baseq3/pak0.pk3 ${dir}/baseq3/pak0.pk3
                dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
                        ${dir}/missionpack/pak0.pk3
        else
@@ -87,23 +87,17 @@ src_install() {
                newconfd "${FILESDIR}"/q3ded.conf.d q3ded
        fi
        newicon quake3.xpm quake3-bin.xpm
+       make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
 
        prepgamesdirs
-       make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
 }
 
 pkg_postinst() {
        games_pkg_postinst
-       echo
        ewarn "There are two possible security bugs in this package, both causing a"
        ewarn "denial of service. One affects the game when running a server, the"
        ewarn "other when running as a client."
        ewarn "For more information, please see bug #82149."
-       if ! use cdinstall ; then
-               echo
-               einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
-               einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
-       fi
        if use dedicated; then
                echo
                einfo "To start a dedicated server, run"
diff --git a/games-fps/quake3-bin/quake3-bin-1.32b-r5.ebuild b/games-fps/quake3-bin/quake3-bin-1.32b-r5.ebuild
new file mode 100644 (file)
index 0000000..7cc22ef
--- /dev/null
@@ -0,0 +1,117 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r5.ebuild,v 1.1 2006/03/27 18:43:12 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://idsoftware/quake3/linux/linuxq3apoint-${PV}-3.x86.run"
+
+LICENSE="Q3AEULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall dedicated opengl teamarena"
+RESTRICT="nostrip"
+
+RDEPEND="sys-libs/glibc
+       opengl? (
+               virtual/opengl
+               x86? (
+                       || (
+                               (
+                                       x11-libs/libXext
+                                       x11-libs/libX11
+                                       x11-libs/libXau
+                                       x11-libs/libXdmcp )
+                               virtual/x11 ) ) )
+       dedicated? (
+               app-misc/screen )
+       amd64? (
+               app-emulation/emul-linux-x86-baselibs
+               opengl? (
+                       app-emulation/emul-linux-x86-xlibs
+                       || (
+                               >=media-video/nvidia-glx-1.0.6629-r3
+                               >=x11-drivers/ati-drivers-8.8.25-r1 ) ) )
+       games-fps/quake3-data
+       teamarena? ( games-fps/quake3-teamarena )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/quake3
+Ddir=${D}/${dir}
+
+pkg_setup() {
+       games_pkg_setup
+       if use cdinstall
+       then
+               built_with_use games-fps/quake3-data cdinstall \
+                       || die "You must install quake3-data with USE=cdinstall to get the required data."
+       fi
+}
+
+src_unpack() {
+       unpack_makeself
+}
+
+src_install() {
+       if use cdinstall ; then
+               dodir ${dir}/{baseq3,missionpack}
+               for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
+                       dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
+               done
+               dosym ${GAMES_DATADIR}/quake3/baseq3/pak0.pk3 ${dir}/baseq3/pak0.pk3
+               use teamarena && dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
+                       ${dir}/missionpack/pak0.pk3
+       else
+               insinto ${dir}/baseq3
+               doins baseq3/*.pk3 || die "ins baseq3"
+               insinto ${dir}/missionpack
+               doins missionpack/*.pk3 || die "ins missionpack"
+       fi
+
+       insinto ${dir}
+       doins -r Docs pb || die "ins docs/pb"
+
+       exeinto ${dir}
+       insinto ${dir}
+       doexe bin/Linux/x86/quake3.x86 || die "doexe"
+       doins quake3.xpm README* Q3A_EULA.txt
+       games_make_wrapper quake3-bin ./quake3.x86 "${dir}" "${dir}"
+       if use dedicated
+       then
+               doexe bin/Linux/x86/q3ded || die "doexe q3ded"
+               games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
+               newinitd "${FILESDIR}"/q3ded.rc q3ded
+               newconfd "${FILESDIR}"/q3ded.conf.d q3ded
+       fi
+       newicon quake3.xpm quake3-bin.xpm
+       make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
+       use teamarena && make_desktop_entry "quake3-bin +set fs_game missionpack" \
+               "Quake III Team Arena" quake3-bin.xpm
+
+       prepgamesdirs
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       ewarn "There are two possible security bugs in this package, both causing a"
+       ewarn "denial of service. One affects the game when running a server, the"
+       ewarn "other when running as a client."
+       ewarn "For more information, please see bug #82149."
+       if use dedicated; then
+               echo
+               einfo "To start a dedicated server, run"
+               einfo "  /etc/init.d/q3ded start"
+               echo
+               einfo "The dedicated server is started under the ${GAMES_USER_DED} user account."
+       fi
+
+       # IA32 Emulation required for amd64
+       if use amd64 ; then
+               echo
+               ewarn "NOTE: IA32 Emulation must be compiled into your kernel for Quake3 to run."
+       fi
+}
index 646233c6145f3167551840154779ab28e5be041f..e956b348644140d9c129f1b0cad3790133632258 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-fps/quake3
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.33 2006/03/24 22:13:30 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.34 2006/03/27 18:38:21 wolf31o2 Exp $
+
+  27 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  quake3-1.34_alpha632.ebuild, quake3-9999.ebuild:
+  Added initial support for quake3-teamarena.
 
   24 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
   -quake3-1.33_alpha510.ebuild:
index b980d2fc2d8565564855094d09185b21ef7c17a6..1171c84aa2ecc5184f29ee9fef5f68386e53f559 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha632.ebuild,v 1.2 2006/03/24 20:01:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha632.ebuild,v 1.3 2006/03/27 18:38:21 wolf31o2 Exp $
 
 # quake3-9999          -> latest svn
 # quake3-9999.REV      -> use svn REV
 if [[ ${PV} == 9999* ]] ; then
        [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
        ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
-       inherit subversion games toolchain-funcs
+       inherit subversion toolchain-funcs eutils games
 
        SRC_URI=""
        S=${WORKDIR}/trunk
 elif [[ ${PV} == *_alpha* ]] ; then
-       inherit games toolchain-funcs
+       inherit toolchain-funcs eutils games
 
        MY_PV=${PV/_alpha*/}
        SNAP=${PV/*_alpha/}
@@ -23,7 +23,7 @@ elif [[ ${PV} == *_alpha* ]] ; then
        SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
        S=${WORKDIR}/${MY_P}
 else
-       inherit games toolchain-funcs
+       inherit toolchain-funcs eutils games
 
        SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
 fi
@@ -57,7 +57,8 @@ RDEPEND="opengl? (
                                x11-libs/libXdmcp )
                        virtual/x11 )
                media-libs/libsdl )
-       games-fps/quake3-data"
+       games-fps/quake3-data
+       teamarena? ( games-fps/quake3-teamarena )"
 
 src_unpack() {
        if [[ ${PV} == 9999* ]] ; then
@@ -108,7 +109,6 @@ src_install() {
 
 pkg_postinst() {
        games_pkg_postinst
-       echo
        ewarn "The source version of Quake 3 will not work with Punk Buster."
        ewarn "If you need pb support, then use the quake3-bin package."
        echo
index f54b4b9b858f0a8907340892e8afa10cc83c1054..cd544c2d558c221c458ed4ecbb5edfab3558baa4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.1 2006/01/20 01:20:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.2 2006/03/27 18:38:21 wolf31o2 Exp $
 
 # quake3-9999          -> latest svn
 # quake3-9999.REV      -> use svn REV
 if [[ ${PV} == 9999* ]] ; then
        [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
        ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
-       inherit subversion games toolchain-funcs
+       inherit subversion toolchain-funcs eutils games
 
        SRC_URI=""
        S=${WORKDIR}/trunk
 elif [[ ${PV} == *_alpha* ]] ; then
-       inherit games toolchain-funcs
+       inherit toolchain-funcs eutils games
 
        MY_PV=${PV/_alpha*}
        SNAP=${PV/*_alpha}
@@ -23,7 +23,7 @@ elif [[ ${PV} == *_alpha* ]] ; then
        SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
        S=${WORKDIR}/${MY_P}
 else
-       inherit games toolchain-funcs
+       inherit toolchain-funcs eutils games
 
        SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
 fi
@@ -57,7 +57,8 @@ RDEPEND="opengl? (
                                x11-libs/libXdmcp )
                        virtual/x11 )
                media-libs/libsdl )
-       games-fps/quake3-data"
+       games-fps/quake3-data
+       teamarena? ( games-fps/quake3-teamarena )"
 
 src_unpack() {
        if [[ ${PV} == 9999* ]] ; then
@@ -106,7 +107,6 @@ src_install() {
 
 pkg_postinst() {
        games_pkg_postinst
-       echo
        ewarn "The source version of Quake 3 will not work with Punk Buster."
        ewarn "If you need pb support, then use the quake3-bin package."
        echo