x11-misc/unclutter: EAPI bump 5 -> 6
authorHarri Nieminen <moikkis@gmail.com>
Thu, 23 Feb 2017 16:41:03 +0000 (18:41 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 14:14:59 +0000 (15:14 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4071

x11-misc/unclutter/unclutter-8-r4.ebuild [moved from x11-misc/unclutter/unclutter-8-r3.ebuild with 75% similarity]

similarity index 75%
rename from x11-misc/unclutter/unclutter-8-r3.ebuild
rename to x11-misc/unclutter/unclutter-8-r4.ebuild
index 260ebc9d0ee8621aa1c76dc4398de20a172fb48e..1372a6c79a666fee3d63f072de079a414ee270cc 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Hides mouse pointer while not in use"
 HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
@@ -20,11 +20,10 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${PN}
 
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-include.patch \
-               "${FILESDIR}"/${P}-FocusOut.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${P}-include.patch
+       "${FILESDIR}"/${P}-FocusOut.patch
+)
 
 src_compile() {
        emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDOPTIONS="${LDFLAGS}"
@@ -33,5 +32,5 @@ src_compile() {
 src_install () {
        dobin unclutter
        newman unclutter.man unclutter.1x
-       dodoc README
+       einstalldocs
 }