sys-fs/encfs: add slot equals matching for boost and openssl
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 12:34:04 +0000 (08:34 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 12:34:52 +0000 (08:34 -0400)
Gentoo-Bug: 557414

Package-Manager: portage-2.2.20.1

sys-fs/encfs/encfs-1.7.5.ebuild
sys-fs/encfs/encfs-1.8.1.ebuild

index 7214cdad2e9b15dff6f9f89b64ace88e7ad874ca..07f9147e36d4ddb1f7adf0eb36170241bf086541 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=2
+EAPI=5
 inherit autotools eutils multilib
 
 DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
@@ -14,8 +14,8 @@ SLOT="0"
 KEYWORDS="amd64 ~arm ~sparc x86"
 IUSE="xattr"
 
-RDEPEND=">=dev-libs/boost-1.34
-       >=dev-libs/openssl-0.9.7
+RDEPEND="dev-libs/boost:=
+       dev-libs/openssl:=
        >=dev-libs/rlog-1.4
        >=sys-fs/fuse-2.7.0
        sys-libs/zlib"
index 62024ad930e9fdc84a764dd8680054122dbd8e7c..abbaf69c6ca0271974b1cf6a70d3c559339702d5 100644 (file)
@@ -14,10 +14,10 @@ SLOT="0"
 KEYWORDS="amd64 ~arm ~sparc ~x86"
 IUSE="xattr nls"
 
-RDEPEND=">=dev-libs/boost-1.34
-       >=sys-fs/fuse-2.5
-       >=dev-libs/openssl-0.9.7
+RDEPEND="dev-libs/boost:=
+       dev-libs/openssl:=
        >=dev-libs/rlog-1.3
+       >=sys-fs/fuse-2.5
        sys-libs/zlib"
 # Your libc probably provides xattrs, but to be safe
 # we'll dep on sys-apps/attr.  This should be fixed