dev-ros/roslib: Bump to 1.12.5.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 15 Oct 2015 09:25:47 +0000 (11:25 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 15 Oct 2015 11:25:34 +0000 (13:25 +0200)
Package-Manager: portage-2.2.23

dev-ros/roslib/Manifest
dev-ros/roslib/roslib-1.12.5.ebuild [new file with mode: 0644]

index 02c7ccc4a2ae71bba62a75aa840664a7bbba0955..15d69cf560d6e605caf4d33fc7cfa1e0a9dba82b 100644 (file)
@@ -1 +1,2 @@
 DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
+DIST ros-1.12.5.tar.gz 162845 SHA256 13233fce9ad605c9a9d7da7c40df8babf6bf1ca6b5e7605b57aa451fb03ee83c SHA512 db67da9ba13afa516aea64d2d42cbfd07ddd7f87d5a6db7506a9f80af8eea0ac2bd85251a10b8f07a7384d3de869c46a354fa003d8e834a0ab5fdf26ed991314 WHIRLPOOL bfe4f06f318d5d39d5d3690fa9fdcb75ad622018ee4ad527d9be2ca60b0096c4dde5632d089e0de817337e26bbf2ca169724d0fe634587802cb10cc0ad0db254
diff --git a/dev-ros/roslib/roslib-1.12.5.ebuild b/dev-ros/roslib/roslib-1.12.5.ebuild
new file mode 100644 (file)
index 0000000..5530a2d
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Base dependencies and support libraries for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-libs/boost:=[threads]
+       dev-ros/rospack
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"