dev-python/httpretty: Bump to 0.9.6
authorMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 06:38:27 +0000 (08:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 07:07:39 +0000 (09:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httpretty/Manifest
dev-python/httpretty/httpretty-0.9.6.ebuild [new file with mode: 0644]

index 6a66df776e079c56920c831d94250a2abd411076..f9a8c98a04d7035bdf15da060a0f0187178bd85a 100644 (file)
@@ -1 +1,2 @@
 DIST httpretty-0.8.14.tar.gz 43574 BLAKE2B 4015bb234c2fe3017a43fff6e3b51a7f015d9d133756d4326750da1ea06ce1910d91d7b47625a08ec85856d156a0d8b3b18706e582578e3d186994b8e4f55c69 SHA512 5adab6450e8360cc21bab4136f64cd11757b9f292c7e27980fe2561f3e705baf4f0211b9e6ff4ec9ba96a788a6c5b5b1d26657972b67423c9c25491927b0884b
+DIST httpretty-0.9.6.tar.gz 7147633 BLAKE2B e1d02ddfce5ca987c6ef1a17723544f86a8573c2a6a26ec197072021e52015efce5064af21bfbe1ec03f3ac11c21717a80f114b5be2526b113e3bc0a608702f4 SHA512 bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92
diff --git a/dev-python/httpretty/httpretty-0.9.6.ebuild b/dev-python/httpretty/httpretty-0.9.6.ebuild
new file mode 100644 (file)
index 0000000..f65d190
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/urllib3[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+               dev-python/sure[${PYTHON_USEDEP}]
+               dev-python/httplib2[${PYTHON_USEDEP}]
+               >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+               >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+       # remove useless deps
+       sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}