dev-python/cryptography: Enable pypy as Python target
authorSean Vig <sean.v.775@gmail.com>
Sat, 22 Aug 2015 23:12:57 +0000 (18:12 -0500)
committerSean Vig <sean.v.775@gmail.com>
Sun, 23 Aug 2015 02:41:58 +0000 (21:41 -0500)
dev-python/cryptography/cryptography-1.0.ebuild

index c06bcfde5b5a080a78d02c2ce565c885908f7166..89753712433b020fdccf8ec469fd6d2729b603c3 100644 (file)
@@ -5,7 +5,7 @@
 EAPI=5
 
 # only works with >=pypy-2.6
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
 
 inherit distutils-r1
 
@@ -27,6 +27,7 @@ RDEPEND="
        >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
        "
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]