net-mail/cmd5checkpw: bump to EAPI 7
authorRolf Eike Beer <eike@sf-mail.de>
Mon, 14 Oct 2019 13:48:22 +0000 (15:48 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 7 Nov 2019 06:07:54 +0000 (08:07 +0200)
Bug: https://bugs.gentoo.org/697248
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Closes: https://github.com/gentoo/gentoo/pull/13299
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-mail/cmd5checkpw/Manifest
net-mail/cmd5checkpw/cmd5checkpw-0.30-r2.ebuild [new file with mode: 0644]

index c0c908bfe4830f686a0b523d593ca56f4316a86a..f8a8d35cf6fdba84bc5561874397e27a540fbe23 100644 (file)
@@ -1 +1,2 @@
 DIST cmd5checkpw-030_tgz.bin 25812 BLAKE2B d1ef48edd2ff0d88823656915a04a8f0893840a49022ed977c6d178cf70d179c44504512ad44d94ae33d48e523ae8cb98ff7b87357b6c8deee761ae9df163bc5 SHA512 c54792769097ac7e8a11c6a140a9eefdb090bad4a0336be9543549a232e4faa72f08baea7e746b9743e01ce40c0f7402f4584c53b5eedb3f2d1e457d1c8a45d5
+DIST cmd5checkpw-0.30.tar.gz 25812 BLAKE2B d1ef48edd2ff0d88823656915a04a8f0893840a49022ed977c6d178cf70d179c44504512ad44d94ae33d48e523ae8cb98ff7b87357b6c8deee761ae9df163bc5 SHA512 c54792769097ac7e8a11c6a140a9eefdb090bad4a0336be9543549a232e4faa72f08baea7e746b9743e01ce40c0f7402f4584c53b5eedb3f2d1e457d1c8a45d5
diff --git a/net-mail/cmd5checkpw/cmd5checkpw-0.30-r2.ebuild b/net-mail/cmd5checkpw/cmd5checkpw-0.30-r2.ebuild
new file mode 100644 (file)
index 0000000..3a0b969
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fixheadtails
+
+MY_VER=$(ver_rs 1- "")
+
+DESCRIPTION="A checkpassword compatible authentication program that used CRAM-MD5 authentication mode"
+SRC_URI="https://www.fehcom.de/qmail/auth/${PN}-${MY_VER}_tgz.bin -> ${P}.tar.gz"
+HOMEPAGE="https://www.fehcom.de/qmail/smtpauth.html"
+
+LICENSE="public-domain RSA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="acct-user/cmd5checkpw"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       if has_version "<net-mail/cmd5checkpw-0.30"; then
+               ewarn
+               ewarn "this version is in NO WAY COMPATIBLE with cmd5checkpw-0.2x"
+               ewarn "it actually receives the authentication credentials"
+               ewarn "in a different order then the old implementation"
+               ewarn "see bug #100693 for details"
+               ewarn "this version IS needed by >=qmail-1.03-r16"
+               ewarn
+       fi
+}
+
+PATCHES=(
+       "${FILESDIR}"/euid_${MY_VER}.diff
+       "${FILESDIR}"/reloc.diff
+)
+
+src_prepare() {
+       default
+
+       ht_fix_file Makefile
+}
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} -o cmd5checkpw"
+}
+
+src_install() {
+       insinto /etc
+       insopts -m 400 -o cmd5checkpw
+       doins "${FILESDIR}"/poppasswd
+
+       exeinto /usr/bin
+       exeopts -o cmd5checkpw -m 4755
+       doexe cmd5checkpw
+
+       doman cmd5checkpw.8
+       einstalldocs
+}
+
+pkg_postinst() {
+       chmod 400 "${EROOT}"/etc/poppasswd || die
+       chown cmd5checkpw "${EROOT}"/etc/poppasswd || die
+}