dev-python/python-cinderclient: 4.2.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 25 Mar 2020 16:16:52 +0000 (11:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 25 Mar 2020 16:17:17 +0000 (11:17 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-cinderclient/Manifest
dev-python/python-cinderclient/metadata.xml
dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild [new file with mode: 0644]

index aac00f43a1cdb1cd49a1243608c83eaea540e9d1..581f4f910fc2395d7cea2a3c67b6c875f01b16d9 100644 (file)
@@ -1 +1,2 @@
 DIST python-cinderclient-4.2.1.tar.gz 287696 BLAKE2B b79068acfeafd9e8ab85035fcda1cceaacc68d3a847b4d070fcb16efdf103ad362c21196afc0ea23eba6a9110f5e96d8de8e2446889740c9abccd912a972358d SHA512 e72af1163bbd882354aea3b7ecdc36cad0899589430e31006f9b1f5f1d00866c9c0de631d2a94b83b3dc358039069adefef54231ecb191ad167339ca3a37a588
+DIST python-cinderclient-4.2.2.tar.gz 289041 BLAKE2B c397c530a040f340d8b39d33348299c547f4591e0046c89644014e3ecdb1163c2b7d46111609ffb6586ed4dd70ae7c1a9f2895046ac7650d101cb6581a5f758f SHA512 fbbdf3828bc13c316c148290575a5efc349c02123bde0f965e11d504cb690fdda9c18af36aa4fc7c6289dc809b45aca41721c3f30b71d088bda2733c785c5ef9
index 1270d0b5f8160224eb9cb60ba8a8506b0a9da78d..89b79ab63e405fa2bc2d6c33eb2d507b607a12d4 100644 (file)
@@ -9,9 +9,6 @@
     <email>openstack@gentoo.org</email>
     <name>Openstack</name>
   </maintainer>
-  <longdescription lang="en">
-    This is a client for the OpenStack Cinder API.
-  </longdescription>
   <upstream>
     <remote-id type="pypi">python-cinderclient</remote-id>
     <remote-id type="launchpad">python-cinderclient</remote-id>
diff --git a/dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild b/dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild
new file mode 100644 (file)
index 0000000..5bce909
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+       >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}