dev-ros/geodesy: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:52:22 +0000 (10:52 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:52:22 +0000 (10:52 +0200)
Package-Manager: portage-2.2.21

dev-ros/geodesy/Manifest [new file with mode: 0644]
dev-ros/geodesy/geodesy-0.4.0.ebuild [new file with mode: 0644]
dev-ros/geodesy/geodesy-9999.ebuild [new file with mode: 0644]
dev-ros/geodesy/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
new file mode 100644 (file)
index 0000000..ffc2215
--- /dev/null
@@ -0,0 +1 @@
+DIST geographic_info-0.4.0.tar.gz 26981 SHA256 7e31afeeb319e67242304445b690f345d6b66993ab0be582e36a454f7ac8eca4 SHA512 1296ad824caacf0a1240468dbc979c647e8d412246ca8aae19f2091487ab2b9c9ec2c3fe3f3eb92f0b662f318b005a34072555bad6b3d979c1463464f303764d WHIRLPOOL d9865cea02597df7421739c56fc32fd3029c0ebf6a1558a4ee701cb0025269bdb6c735598c0aa411aa7736bfb10fdd554842b7c2e1c96e3b2ebb28a6686e50f6
diff --git a/dev-ros/geodesy/geodesy-0.4.0.ebuild b/dev-ros/geodesy/geodesy-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..a514643
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/angles
+       dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf
+       dev-ros/unique_id
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-python/pyproj[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-ros/rosunit[${PYTHON_USEDEP}]
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
new file mode 100644 (file)
index 0000000..a514643
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/angles
+       dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf
+       dev-ros/unique_id
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-python/pyproj[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-ros/rosunit[${PYTHON_USEDEP}]
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
diff --git a/dev-ros/geodesy/metadata.xml b/dev-ros/geodesy/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>