sys-apps/irqbalance: Fixed USE="-caps" still linking to libcaps
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 9 Jul 2018 12:34:14 +0000 (14:34 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 9 Jul 2018 12:34:46 +0000 (14:34 +0200)
Also revbumped to 1.4.0-r1 with added "tui" USE flag.

Bug: https://bugs.gentoo.org/660782
Package-Manager: Portage-2.3.41, Repoman-2.3.9

sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch [new file with mode: 0644]
sys-apps/irqbalance/irqbalance-1.3.0.ebuild
sys-apps/irqbalance/irqbalance-1.4.0-r1.ebuild [moved from sys-apps/irqbalance/irqbalance-1.4.0.ebuild with 88% similarity]
sys-apps/irqbalance/metadata.xml

diff --git a/sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch b/sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch
new file mode 100644 (file)
index 0000000..6008e45
--- /dev/null
@@ -0,0 +1,68 @@
+From 8ad74cdabac37599d20a985e6a456b1faca92df8 Mon Sep 17 00:00:00 2001
+From: Manuel Mommertz <2kmm@gmx.de>
+Date: Mon, 9 Jul 2018 14:08:35 +0200
+Subject: [PATCH 1/2] configure.ac: Fix --without-caps option
+
+irqbalance links to libcap-ng if it is installed, even when useflag
+caps is disabled. This is an error in the configure-script, which
+checks for the wrong variable to determine if the user used --with/
+--without for libcap-ng.
+
+Downstream bug report: https://bugs.gentoo.org/660782
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f6c60da..19b148a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,7 +65,7 @@ AC_ARG_WITH([libcap-ng],
+   AS_HELP_STRING([libcap-ng], [Add libcap-ng-support @<:@default=auto@:>@]))
+ AS_IF(
+-  [test "x$libcap_ng" != "xno"],
++  [test "x$with_libcap_ng" != "xno"],
+   [
+   PKG_CHECK_MODULES([LIBCAP_NG], [libcap-ng],
+     [AC_DEFINE(HAVE_LIBCAP_NG,1,[libcap-ng support])],
+-- 
+2.18.0
+
+From bc56dbd4eead9ad19ff1d84dc8810123c96503c0 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 9 Jul 2018 14:11:44 +0200
+Subject: [PATCH 2/2] configure.ac: Fix --enable-irqbalance-ui logic
+
+Before this patch --enable-irqbalance-ui disabled compilation/
+installation of the ui because AC_ARG_WITH is used wrong.
+The third arguement to AC_ARG_WITH is _action-if-present_ which means
+that this action gets triggered once the --enable option has been
+submitted to configure on command line no matter if it's enabled or
+disabled.
+See also https://autotools.io/autoconf/arguments.html chapter 3.1
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 19b148a..75c234d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -43,9 +43,9 @@ AM_PROG_CC_C_O
+ AC_ARG_WITH([irqbalance-ui],
+       [AC_HELP_STRING([--without-irqbalance-ui],
+                       [Dont build the irqbalance ui component])],
+-                      [with_irqbalanceui=false], [with_irqbalanceui=true])
++                      [with_irqbalanceui=$withval], [with_irqbalanceui=yes])
+-AM_CONDITIONAL([IRQBALANCEUI], [test x$with_irqbalanceui = xtrue])
++AM_CONDITIONAL([IRQBALANCEUI], [test x$with_irqbalanceui = xyes])
+ AC_ARG_WITH([systemd],
+   [ AS_HELP_STRING([--with-systemd],[Add systemd-lib support])]
+-- 
+2.18.0
+
index 144745c1bc8bae75455a3771770bbbb799368a46..e8685a791611d5ab0cd99d54cf6839dd2e7fd615 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
-AUTOTOOLS_AUTORECONF=true
 
 inherit autotools systemd linux-info
 
@@ -28,6 +27,10 @@ RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-irqbalance )
 "
 
+PATCHES=(
+       "${FILESDIR}/${PN}-1.4.0-configure.patch"
+)
+
 pkg_setup() {
        CONFIG_CHECK="~PCI_MSI"
        linux-info_pkg_setup
similarity index 88%
rename from sys-apps/irqbalance/irqbalance-1.4.0.ebuild
rename to sys-apps/irqbalance/irqbalance-1.4.0-r1.ebuild
index a38439a45dc535b88e6174ae518d2451f2bfaa8c..c3874ddf72d99bf3235a11acd68ba4a7b2e1f3bc 100644 (file)
@@ -2,7 +2,6 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
-AUTOTOOLS_AUTORECONF=true
 
 inherit autotools systemd linux-info
 
@@ -13,13 +12,13 @@ SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="caps +numa selinux"
+IUSE="caps +numa selinux tui"
 
 CDEPEND="
        dev-libs/glib:2
-       sys-libs/ncurses:0=[unicode]
        caps? ( sys-libs/libcap-ng )
        numa? ( sys-process/numactl )
+       tui? ( sys-libs/ncurses:0=[unicode] )
 "
 DEPEND="${CDEPEND}
        virtual/pkgconfig
@@ -28,6 +27,10 @@ RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-irqbalance )
 "
 
+PATCHES=(
+       "${FILESDIR}/${P}-configure.patch"
+)
+
 pkg_setup() {
        CONFIG_CHECK="~PCI_MSI"
        linux-info_pkg_setup
@@ -50,8 +53,8 @@ src_configure() {
        local myeconfargs=(
                $(use_with caps libcap-ng)
                $(use_enable numa)
-               )
-
+               $(use_with tui irqbalance-ui)
+       )
        econf "${myeconfargs[@]}"
 }
 
index 8aa1af6dd70942028bce6c67dff8ca18a5d735e8..d4dedf3afa55b774a8dc5f43f6e1520d3319f7d6 100644 (file)
@@ -7,6 +7,7 @@
 </maintainer>
 <use>
        <flag name="numa">Support balancing IRQs across NUMA nodes</flag>
+       <flag name="tui">Enable build of irqbalance terminal user interface</flag>
 </use>
 <upstream>
        <remote-id type="google-code">irqbalance</remote-id>