Ebuild cleanup, set mysql as herd too.
authorLuca Longinotti <chtekk@gentoo.org>
Thu, 7 Dec 2006 16:36:01 +0000 (16:36 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Thu, 7 Dec 2006 16:36:01 +0000 (16:36 +0000)
Package-Manager: portage-2.1.2_rc2-r2

net-www/mod_auth_mysql/ChangeLog
net-www/mod_auth_mysql/metadata.xml
net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild

index 90ad87007218159653fcc4487f220f4a0ddc2ef0..07a863076ca4251fb7a437a21d4a2535bc88fcf0 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-www/mod_auth_mysql
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.23 2006/11/23 16:14:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.24 2006/12/07 16:36:01 chtekk Exp $
+
+  07 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
+  -files/12_mod_auth_mysql.conf, -files/mod_auth_mysql.patch, metadata.xml,
+  -mod_auth_mysql-3.0.0.ebuild, mod_auth_mysql-3.0.0-r1.ebuild:
+  Ebuild cleanup, set mysql as herd too.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
   mod_auth_mysql-3.0.0.ebuild, mod_auth_mysql-3.0.0-r1.ebuild:
index ff5b6490402ee27b49f6e4b711d55247db5410d1..1bd30cf257590170db9a4695ffcadd17d0c94831 100644 (file)
@@ -1,8 +1,6 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>apache</herd>
-<maintainer>
-  <email>apache-bugs@gentoo.org</email>
-</maintainer>
+       <herd>apache</herd>
+       <herd>mysql</herd>
 </pkgmetadata>
index 6e40465dee8b2944a11268d478caee161aca49f1..092f3e9bcf87fbbb5181c073626933af3466b36c 100644 (file)
@@ -1,18 +1,21 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.2 2006/11/23 16:14:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.3 2006/12/07 16:36:01 chtekk Exp $
 
-inherit eutils apache-module
+inherit apache-module
 
-DESCRIPTION="Basic authentication for Apache using a MySQL database"
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database."
 HOMEPAGE="http://modauthmysql.sourceforge.net/"
 SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
-
-DEPEND="virtual/mysql"
 LICENSE="Apache-1.1"
-KEYWORDS="~amd64 ~x86"
 SLOT="0"
 
+DEPEND="virtual/mysql
+               sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
 BASE_CONFIG_PVR="2.8.1"
 
 APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
@@ -28,14 +31,13 @@ DOCFILES="README"
 need_apache
 
 pkg_postinst() {
-       if ! useq apache2; then
-               ewarn "With regard to bug #132391 the behaviour of mod_auth_mysql"
-               ewarn "has changed for apache-1.3.x"
-               ewarn
-               ewarn "You need to enable mod_auth_ldap in your .htaccess files"
-               ewarn "explicitely using:"
-               ewarn
-               ewarn "  AuthMySQLEnable On"
-               ewarn
+       if ! useq apache2 ; then
+               elog "With regard to bug #132391 the behaviour of ${PN}"
+               elog "has changed for Apache-1.3.XX."
+               elog
+               elog "You now need to enable ${PN} in your .htaccess"
+               elog "files explicitely using:"
+               elog
+               elog "  AuthMySQLEnable On"
        fi
 }