app-admin/consul: increase max open files
authorZac Medico <zachary.medico@sony.com>
Mon, 15 Jul 2019 20:11:36 +0000 (13:11 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 15 Jul 2019 20:27:08 +0000 (13:27 -0700)
See: https://learn.hashicorp.com/consul/datacenter-deploy/deployment-guide#configure-systemd
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Copyright: Sony Interactive Entertainment Inc.
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-admin/consul/consul-1.5.1-r1.ebuild [moved from app-admin/consul/consul-1.5.1.ebuild with 100% similarity]
app-admin/consul/files/consul.initd
app-admin/consul/files/consul.service

index 6d04eb56430647a41cbbd7d7d4007c14ea7c5ca1..00a65695fa2b62e94c1b94fdf4d6326fbc8d973f 100644 (file)
@@ -7,6 +7,7 @@ extra_started_commands="reload"
 group=${group:-${RC_SVCNAME}}
 user=${user:-${RC_SVCNAME}}
 pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"}
+rc_ulimit=${rc_ulimit-"-n 65536"}
 command="/usr/bin/${RC_SVCNAME}"
 command_args="agent ${command_args:-config-dir=/etc/consul.d}"
 command_background="true"
index be897bcf8e97d4e8f3d6870bd290ad3b0562c267..7839d7c20a87dd0eede88315131e0dc81c657b0e 100644 (file)
@@ -5,10 +5,13 @@ After=network-online.target
 
 [Service]
 User=consul
+Group=consul
 Environment=CONSUL_AGENT_OPTS="-config-dir=/etc/consul.d"
 ExecStart=/usr/bin/consul agent $CONSUL_AGENT_OPTS
-Restart=on-failure
 ExecReload=/usr/bin/consul reload
+KillMode=process
+Restart=on-failure
+LimitNOFILE=65536
 
 [Install]
 WantedBy=default.target