dev-libs/xmlsec: cleanup ebuild
authorAlon Bar-Lev <alonbl@gentoo.org>
Tue, 16 Apr 2019 21:01:54 +0000 (00:01 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Tue, 16 Apr 2019 21:02:06 +0000 (00:02 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-libs/xmlsec/xmlsec-1.2.28.ebuild

index 1e5834c6fbb171050bd1207de55f5075a70bbc6f..50ec11983a80f4ea63f774f9e246edd71b6aa312 100644 (file)
@@ -42,26 +42,17 @@ PATCHES=(
        "${FILESDIR}/${P}-test.patch"
 )
 
-src_prepare() {
-       default
-       # conditionally install extra documentation
-       if ! use doc ; then
-               sed -i '/^SUBDIRS/s/docs//' Makefile.am || die
-               eautoreconf
-       fi
-}
-
 src_configure() {
        econf \
-               --enable-pkgconfig \
-               --with-html-dir=/usr/share/doc/${PF}/html \
+               $(use_enable doc docs) \
                $(use_enable static-libs static) \
                $(use_with gcrypt) \
                $(use_with gnutls) \
-               $(use_with nss) \
                $(use_with nss nspr) \
+               $(use_with nss) \
                $(use_with openssl) \
-               $(use_enable openssl aes)
+               --enable-mans \
+               --enable-pkgconfig
 }
 
 src_test() {