media-libs/compface: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:07 +0000 (18:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:07 +0000 (18:31 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/compface/compface-1.5.2.ebuild
media-libs/compface/files/compface-1.5.2-destdir.diff [deleted file]
media-libs/compface/files/compface-1.5.2-fix-build-system.patch [new file with mode: 0644]

index af03c528e50568f5d277da4f8242e9a1adfce51a..db1dd3858f064c1b98cf7b86e7e44b65054ebb34 100644 (file)
@@ -1,9 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Utilities and library to convert to/from X-Face format"
 HOMEPAGE="http://www.xemacs.org/Download/optLibs.html"
@@ -12,15 +10,12 @@ SRC_URI="http://ftp.xemacs.org/pub/xemacs/aux/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-destdir.diff
-       sed -i "/strip/d" Makefile.in
-}
+RDEPEND="dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
 
 src_install() {
-       emake DESTDIR="${D}" install
-       dodoc ChangeLog README
+       default
        newbin xbm2xface{.pl,}
 }
diff --git a/media-libs/compface/files/compface-1.5.2-destdir.diff b/media-libs/compface/files/compface-1.5.2-destdir.diff
deleted file mode 100644 (file)
index 18ecfd1..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- compface-1.5.2.orig/Makefile.in
-+++ compface-1.5.2/Makefile.in
-@@ -1,10 +1,10 @@
- prefix          = @prefix@
- exec_prefix     = @exec_prefix@
- srcdir          = @srcdir@
--BINDIR                = @bindir@
--LIBDIR                = @libdir@
--MANDIR                = @mandir@
--INCLUDEDIR    = @includedir@
-+BINDIR                = $(DESTDIR)/@bindir@
-+LIBDIR                = $(DESTDIR)/@libdir@
-+MANDIR                = $(DESTDIR)/@mandir@
-+INCLUDEDIR    = $(DESTDIR)/@includedir@
- @SET_MAKE@
diff --git a/media-libs/compface/files/compface-1.5.2-fix-build-system.patch b/media-libs/compface/files/compface-1.5.2-fix-build-system.patch
new file mode 100644 (file)
index 0000000..2cfea74
--- /dev/null
@@ -0,0 +1,28 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1,10 +1,10 @@
+ prefix          = @prefix@
+ exec_prefix     = @exec_prefix@
+ srcdir          = @srcdir@
+-BINDIR                = @bindir@
+-LIBDIR                = @libdir@
+-MANDIR                = @mandir@
+-INCLUDEDIR    = @includedir@
++BINDIR                = $(DESTDIR)/@bindir@
++LIBDIR                = $(DESTDIR)/@libdir@
++MANDIR                = $(DESTDIR)/@mandir@
++INCLUDEDIR    = $(DESTDIR)/@includedir@
+ @SET_MAKE@
+@@ -77,10 +77,8 @@
+               $(INSTALL_PROGRAM) -d $(BINDIR) $(LIBDIR) $(MAN1DIR) $(MAN3DIR) $(INCLUDEDIR)
+               $(INSTALL_PROGRAM) $(srcdir)/$(NAMEEXE) $(EXECUTABLE) 
+               -chmod 0755 $(EXECUTABLE)
+-              -strip $(EXECUTABLE)
+               $(INSTALL_PROGRAM) $(srcdir)/$(UNNAMEEXE) $(UNEXECUTABLE)
+               -chmod 0755 $(UNEXECUTABLE)
+-              -strip $(UNEXECUTABLE)
+               $(INSTALL_DATA) $(srcdir)/$(NAME).1 $(MAN1DIR)/$(NAME).1
+               cd $(MAN1DIR) && $(RM) ./$(UNNAME).1 && $(LN_S) $(NAME).1 $(UNNAME).1
+               $(INSTALL_DATA) $(srcdir)/$(NAME).3 $(MAN3DIR)/$(NAME).3