dev-python/path-py: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Fri, 21 Aug 2015 17:17:06 +0000 (19:17 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 21 Aug 2015 17:19:51 +0000 (19:19 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/path-py/Manifest
dev-python/path-py/path-py-7.6.1.ebuild [new file with mode: 0644]

index f5e068148d7caaf87e90466713aadf04bdb62ac0..2ee973c2c277d9fa25c142f080890778e3bb4c25 100644 (file)
@@ -1,2 +1,3 @@
 DIST path.py-7.3.zip 33549 SHA256 f7d146f40768e3742199a5316fbe3eb6a6091b9feedcb4b969c7348dc03151e1 SHA512 f676b81deda7b42a2a29fef0827d7c8ecbe743d0fa5efdc8221a78f3e744f357a179a9b8451264636ca2626f58d422a02d6ad77cc57eef74dd3b186585863433 WHIRLPOOL 7da96c488aa6bcdea0a65c69b412710dbc85f7bed04dd571389ca190d43fea2e711659ca3546b926efc69d631a1408b5905839c39866d7e98b7dde19803d0c4f
 DIST path.py-7.4.tar.gz 27256 SHA256 69df64c911a4b27194e24b0b81789f449e2b75af46ffbd872e66c9af20009948 SHA512 5a0d34e911315bc447ba9428a7934f77043ec701ecd32e099562290d8c8e092fd780b3ec1f0353c378394e4de2fe444a4141bd91301f40c0fb3086892726205f WHIRLPOOL 41b5025654ea2ae88c829eb10f7fb6341f214e7d9050aca018fcce2349ecae14f08b9398a6743fbae752800742f06dc33a8b3a55a8171eaa8676cf0f72cd9b31
+DIST path.py-7.6.1.tar.gz 32974 SHA256 201c86613327f2f6c2d34c8f28689bdfde74fbb758c5211a1f8652dc71fa9e5a SHA512 f0879018bc5dbc3c5796a0587976f7bd40c44d62c4d81884efef2aca914b0ed14aada3f94c5ad6b8ac6cf8dbc809ff231ca4308d64438c38feafccbba478f796 WHIRLPOOL bb492d8ed4acb0b6c088c36acaba863514f85b46373fe98abd8f6edaf43ea9629340de128cbf2d385a81ccd923325870449553071bf0b967d28a9af1c54c87e1
diff --git a/dev-python/path-py/path-py-7.6.1.ebuild b/dev-python/path-py/path-py-7.6.1.ebuild
new file mode 100644 (file)
index 0000000..7ae500b
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/appdirs[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+       sed '/setuptools_scm/d' -i setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       esetup.py test
+}