dev-java/jgoodies-looks: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 11 Feb 2016 14:30:53 +0000 (14:30 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 11 Feb 2016 14:41:47 +0000 (14:41 +0000)
Package-Manager: portage-2.2.26
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/jgoodies-looks/Manifest
dev-java/jgoodies-looks/files/build.xml [deleted file]
dev-java/jgoodies-looks/files/jgoodies-looks-2.0.4-build.xml.patch [deleted file]
dev-java/jgoodies-looks/files/plastic.txt [deleted file]
dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r1.ebuild [deleted file]
dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild [deleted file]
dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild [deleted file]
dev-java/jgoodies-looks/jgoodies-looks-2.3.1.ebuild [deleted file]

index 7aa430b6b3be60ad8cb50a64572689c7597d9524..e5d55453b2e4efc0699a74ae11cd9acdd905995e 100644 (file)
@@ -1,3 +1 @@
 DIST jgoodies-looks-2_6_0.zip 2444893 SHA256 2f992c25309e00aadba7c6a3af5c6596b3d487bff64fb1a5e94921647929f7e5 SHA512 1c33413379f391109d1db35bdf301acf0cc6d66bf8aa1026280015946bddb230b4cc1d233b700d46a519fb02c169df4670c874058f5e636e1e924a9d3a42442a WHIRLPOOL f6848e9011001353cb115298465e7da981335d15f3839ca749418d975965358bc9595dbf9a1a36be9b240d0b92866a953dc4a7500b2eb8ecfe50ce46b5e40973
-DIST looks-1_2_2.zip 1811849 SHA256 d7b6cc296cf9284bcbeda9a2c9497e804abae66ae3fc3f31174cf19e9a0bebae SHA512 d9c5f0590a44dbc7d778a9da135361f5753eca4d47bef3636f21aa0d014df86dbad90031b5289928b99c352147ea702948028b18b36eb3bc44aef800326fb302 WHIRLPOOL 20b67ffb888322967103de3953ce825976582f5031ee1609acc91c86d9a621d22656b3337734ecee447c665b35784c595165f7732f2eb0fccc988fa4ac734235
-DIST looks-2_3_1.zip 2105839 SHA256 f66b7e79ca53e849d6082ba0d937f9056d855cd6269edb9b3c52dd1347b14b8d SHA512 61278cc0b8556ce19cfb5bdaaab2b42d7035fcdf71d614a8d3673629d5b04c5698e2be521df3e0518e781f78c03a8d3f466f1fdfba525f679e9de7409faf1088 WHIRLPOOL 964806f73587ed116e4cfb6c330f0231598fc651286085c40bd4a6acedc9a1565bdbe5a4ff48f3e7dfb976a4a28ca667994d146b3d3bc9bfbeacf3c520915425
diff --git a/dev-java/jgoodies-looks/files/build.xml b/dev-java/jgoodies-looks/files/build.xml
deleted file mode 100644 (file)
index b24ec32..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-<?xml version="1.0"?>
-
-<project name="Plastic" default="jar" basedir=".">
-   
-   <!-- This is a customized build.xml for portage! -->
-   <!--
-      <property file="${basedir}/build.properties"/>
-      <property file="${basedir}/default.properties"/>
-   -->
-
-   <property name="build" value="${basedir}/build"/>
-
-   <property name="spec.title" value="JGoodies Looks"/>
-   <property name="spec.version" value="1.2"/>
-   <property name="spec.vendor" value="Apache Software Foundation"/>
-   <property name="imp.title" value="com.jgoodies.plaf"/>
-   <property name="imp.version" value="1.2.2"/>
-   <property name="imp.vendor" value="Apache Software Foundation"/>
-
-   <property name="plaf.src" value="${basedir}/com/jgoodies/plaf"/>
-   <property name="clearlook.src" value="${basedir}/com/jgoodies/clearlook"/>
-
-   <property name="clearlook.javadoc" value="${build}/doc/clearlook"/>
-   <property name="clearlook.packages" value="com.jgoodies.clearlook.*"/>
-
-   <property name="plastic.javadoc" value="${build}/doc/plastic"/>
-   <property name="plastic.packages" value="com.jgoodies.clearlook.*"/>
-   
-   <target name="init">
-      <tstamp />
-      <mkdir dir="${build}"/>
-      <mkdir dir="${build}/doc"/>
-   </target>
-
-   <target name="manifest" depends="init">
-      <manifest file="MANIFEST.MF" mode="update">
-         <attribute name="Built-By" value="Gentoo Portage"/>
-
-         <section name="com/jgoodies/plaf">
-            <attribute name="Specification-Title" value="${spec.title}"/>
-            <attribute name="Specification-Version" value="${spec.version}"/>
-            <attribute name="Specification-Vendor" value="${spec.vendor}"/>
-            <attribute name="Implementation-Title" value="${imp.title}"/>
-            <attribute name="Implementation-Version" value="${imp.version}"/>
-            <attribute name="Implementation-Vendor" value="${imp.vendor}"/>
-         </section>
-      </manifest>
-   </target>
-   
-   <target name="compile" depends="init">
-      <javac srcdir="${plaf.src};${clearlook.src}"
-             destdir="${build}"
-             source="1.4"
-             target="1.4"/>
-      
-      <!--
-         Copy application resources
-         NOTE: THIS MAY NEED TO BE CHANGED IN FUTURE VERSIONS!!
-      -->
-      <copy toDir="${build}/com/jgoodies/plaf">
-         <fileset dir="${plaf.src}" excludes="**/*.java"/>
-      </copy>
-   </target>
-
-   <target name="javadoc" depends="compile">
-      <javadoc sourcepath="${basedir}"
-               destdir="${clearlook.javadoc}"
-               packagenames="${clearlook.packages}"/>
-      <javadoc sourcepath="${basedir}"
-               destdir="${plastic.javadoc}"
-               packagenames="${plastic.packages}"/>
-   </target>
-
-   <target name="jar" depends="compile,manifest">
-      <jar jarfile="looks.jar" manifest="MANIFEST.MF">
-         <fileset dir="${build}"/>
-         <zipfileset dir="${basedir}"
-                     includes="plastic.txt"
-                     fullpath="META-INF/services/javax.swing.LookAndFeel"/>
-      </jar>
-   </target>
-
-</project>
diff --git a/dev-java/jgoodies-looks/files/jgoodies-looks-2.0.4-build.xml.patch b/dev-java/jgoodies-looks/files/jgoodies-looks-2.0.4-build.xml.patch
deleted file mode 100644 (file)
index e6c0a4b..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
---- build.xml.orig     2006-10-12 23:54:26.000000000 +0200
-+++ build.xml  2006-10-12 23:57:36.000000000 +0200
-@@ -100,7 +100,6 @@
-                       srcdir       ="${src.core.dir}"\r
-                       destdir      ="${build.core.dir}"\r
-               encoding     ="${build.encoding}"\r
--              executable   ="${build.compile.executable}"\r
-               fork         ="${build.compile.fork}"\r
-                       debug        ="${build.compile.debug}"\r
-                       depend       ="${build.compile.depend}"\r
-@@ -109,8 +108,7 @@
-                       optimize     ="${build.compile.optimize}"\r
-             source       ="${build.compile.source}"\r
-                       target       ="${build.compile.target}"\r
--                      verbose      ="${build.compile.verbose}"\r
--                      bootclasspath="${build.boot.classpath}" />\r
-+                      verbose      ="${build.compile.verbose}"/>
\r
-               <copy toDir="${build.core.dir}" >\r
-                       <fileset dir="${src.core.dir}" \r
-@@ -127,7 +125,6 @@
-                       srcdir       ="${src.demo.dir}" \r
-                       destdir      ="${build.demo.dir}"\r
-               encoding     ="${build.encoding}"\r
--              executable   ="${build.compile.executable}"\r
-               fork         ="${build.compile.fork}"\r
-                       debug        ="${build.compile.debug}"\r
-                       depend       ="${build.compile.depend}"\r
-@@ -137,7 +134,6 @@
-             source       ="${build.compile.source}"\r
-                       target       ="${build.compile.target}"\r
-                       verbose      ="${build.compile.verbose}"\r
--                      bootclasspath="${build.boot.classpath}" \r
-                   classpathref ="classpath.demo" />\r
-       </target>\r
\r
-@@ -149,7 +145,6 @@
-             srcdir       ="${src.test.dir}" \r
-             destdir      ="${build.test.dir}"\r
-             encoding     ="${build.encoding}"\r
--            executable   ="${build.compile.executable}"\r
-             fork         ="${build.compile.fork}"\r
-             debug        ="${build.compile.debug}"\r
-             depend       ="${build.compile.depend}"\r
-@@ -159,7 +154,6 @@
-             source       ="${build.compile.source}"\r
-             target       ="${build.compile.target}"\r
-             verbose      ="${build.compile.verbose}"\r
--            bootclasspath="${build.boot.classpath}"\r
-             classpathref ="classpath.tests" />\r
-     </target>   \r
-     \r
-@@ -235,7 +229,7 @@
-       </target>\r
-       \r
-     <!-- ***************************************************************** -->\r
--      <target name="jar-all" depends="compile, manifest"\r
-+      <target name="jar-all" depends="compile-core, manifest"\r
-               description="Creates the library jar with all JGoodies l&amp;fs." >\r
\r
-               <jar \r
diff --git a/dev-java/jgoodies-looks/files/plastic.txt b/dev-java/jgoodies-looks/files/plastic.txt
deleted file mode 100644 (file)
index ab3737c..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-# JGoodies Plastic L&F- replacement for Metal
-com.jgoodies.plaf.plastic.PlasticLookAndFeel
-# JGoodies Plastic 3D L&F
-com.jgoodies.plaf.plastic.Plastic3DLookAndFeel
-# JGoodies Plastic XP L&F
-com.jgoodies.plaf.plastic.PlasticXPLookAndFeel
-# JGoodies Windows L&F
-com.jgoodies.plaf.windows.ExtWindowsLookAndFeel
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r1.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r1.ebuild
deleted file mode 100644 (file)
index 03b477a..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit java-pkg-2 java-ant-2
-
-MY_PN="looks"
-MY_PV="${PV//./_}"
-DESCRIPTION="JGoodies Looks Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}-${MY_PV}.zip"
-
-LICENSE="BSD"
-SLOT="1.2"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND=">=virtual/jdk-1.4.2
-       dev-java/ant-core
-       app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4.2"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       rm *.jar
-       unzip ${MY_PN}-${PV}-src.zip &> /dev/null || die "Unpack Failed"
-       cp "${FILESDIR}/build.xml" "${FILESDIR}/plastic.txt" .
-}
-
-src_compile() {
-       eant jar $(use_doc)
-}
-
-src_install() {
-       java-pkg_dojar ${MY_PN}.jar
-
-       dodoc RELEASE-NOTES.txt
-       use doc && java-pkg_dohtml -r build/doc
-}
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild
deleted file mode 100644 (file)
index 8e545b8..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source examples"
-
-inherit java-pkg-2 java-ant-2
-
-MY_PN="looks"
-MY_PV="${PV//./_}"
-
-DESCRIPTION="JGoodies Looks Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}-${MY_PV}.zip"
-
-LICENSE="BSD"
-SLOT="1.2"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND=">=virtual/jdk-1.5
-       app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-EANT_DOC_TARGET="javadoc"
-
-java_prepare() {
-       find -name "*.jar" -delete || die
-       cp "${FILESDIR}/build.xml" "${FILESDIR}/plastic.txt" "${S}" || die
-
-       unzip ${MY_PN}-${PV}-src.zip || die
-}
-
-src_install() {
-       java-pkg_dojar ${MY_PN}.jar
-
-       dodoc RELEASE-NOTES.txt
-       use source && java-pkg_dosrc com
-       use doc && java-pkg_dohtml -r build/doc
-       use examples && java-pkg_doexamples src/examples
-}
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
deleted file mode 100644 (file)
index 705b727..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source examples"
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_PN="looks"
-MY_PV="${PV//./_}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="JGoodies Looks Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="2.0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
-       app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# bug #150970
-EANT_FILTER_COMPILER="jikes"
-# jar target fails unless we make descriptors.dir an existing directory
-# update: it's where it looks for all.txt file
-EANT_EXTRA_ARGS="-Ddescriptors.dir=\"${S}\""
-
-EANT_BUILD_TARGET="jar-all"
-
-java_prepare() {
-       # remove the bootclasspath brokedness, make building demo optional
-       epatch "${FILESDIR}/${PN}-2.0.4-build.xml.patch"
-
-       # unzip the look&feel settings from bundled jar before we delete it
-       unzip -j looks-${PV}.jar META-INF/services/javax.swing.LookAndFeel \
-               || die "unzip of javax.swing.LookAndFeel failed"
-       # and rename it to what build.xml expects
-       mv javax.swing.LookAndFeel all.txt
-
-       find -name "*.jar" -delete || die
-}
-
-src_install() {
-       java-pkg_dojar build/looks.jar
-
-       dodoc RELEASE-NOTES.txt || die
-       dohtml README.html || die
-       use doc && java-pkg_dojavadoc build/docs/api
-       use source && java-pkg_dosrc src/core/com
-       use examples && java-pkg_doexamples src/demo
-}
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.3.1.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1.ebuild
deleted file mode 100644 (file)
index eb34075..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-JAVA_PKG_IUSE="doc source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_PN="looks"
-MY_PV="${PV//./_}"
-MY_P="${MY_PN}-${MY_PV}"
-DESCRIPTION="JGoodies Looks Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="2.0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
-       app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       # remove the bootclasspath brokedness, make building demo optional
-       epatch "${FILESDIR}/${PN}-2.0.4-build.xml.patch"
-
-       # unzip the look&feel settings from bundled jar before we delete it
-       unzip -j looks-${PV}.jar META-INF/services/javax.swing.LookAndFeel \
-               || die "unzip of javax.swing.LookAndFeel failed"
-       # and rename it to what build.xml expects
-       mv javax.swing.LookAndFeel all.txt
-
-       rm -v *.jar demo/*.jar lib/*.jar || die
-       rm -rv docs/api || die
-}
-
-src_compile() {
-       # bug #150970
-       java-pkg_filter-compiler jikes
-
-       # jar target fails unless we make descriptors.dir an existing directory
-       # I checked the ustream binary distribution and they also don't actually
-       # put anything there.
-       # 31.7.2006 betelgeuse@gentoo.org
-       # update: it's where it looks for all.txt file
-       # 16.1.2007 caster@gentoo.org
-       eant -Ddescriptors.dir="${S}" jar-all $(use_doc)
-}
-
-src_install() {
-       java-pkg_dojar build/looks.jar
-
-       dodoc RELEASE-NOTES.txt || die
-       dohtml README.html || die
-       if use doc; then
-               java-pkg_dohtml -r docs/*
-               java-pkg_dojavadoc build/docs/api
-       fi
-       use source && java-pkg_dosrc src/core/com
-}