dev-util/bin_replace_string: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:16 +0000 (20:11 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:16 +0000 (20:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/bin_replace_string/bin_replace_string-0.2.ebuild

index d51ab7696095e19bd22d8099d7c98087bd918b0d..39ed0c289e8d5ee3369190ae48dbda26df92aedc 100644 (file)
@@ -1,27 +1,20 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
 
 DESCRIPTION="A tool to edit C strings in compiled binaries"
 HOMEPAGE="http://ohnopub.net/~ohnobinki/bin_replace_string"
 SRC_URI="ftp://mirror.ohnopub.net/mirror/${P}.tar.bz2"
-LICENSE="AGPL-3"
 
+LICENSE="AGPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="doc"
 
 RDEPEND="virtual/libelf:0"
-DEPEND="doc? ( app-text/txt2man )
-       ${RDEPEND}"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/txt2man"
 
 src_configure() {
-       local myeconfargs=(
-               $(use_enable doc)
-       )
-
-       autotools-utils_src_configure
+       econf --enable-doc
 }