dev-python/pytrie: Modernize, add tests, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 11:17:08 +0000 (12:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 11:21:09 +0000 (12:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytrie/pytrie-0.3.1-r1.ebuild [moved from dev-python/pytrie/pytrie-0.3.1.ebuild with 79% similarity]

similarity index 79%
rename from dev-python/pytrie/pytrie-0.3.1.ebuild
rename to dev-python/pytrie/pytrie-0.3.1-r1.ebuild
index 565ed0863459576ddb19cc05372af7e977791d23..412387da3573a970212439f8592577b818f7e507 100644 (file)
@@ -1,23 +1,23 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
 MY_PN="PyTrie"
 MY_P="${MY_PN}-${PV}"
-
 DESCRIPTION="A pure Python implementation of the trie data structure"
 HOMEPAGE="https://github.com/gsakkis/pytrie/ https://pypi.org/project/PyTrie/"
 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
 
-DEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
 
-S="${WORKDIR}/${MY_P}"
+distutils_enable_tests setup.py