app-arch/cabextract: Move export to local scope
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:13:07 +0000 (18:13 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:30:35 +0000 (18:30 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-arch/cabextract/cabextract-1.6.ebuild

index a56604b1865126b975e2f90c907e149a0d02b995..f9c458b3d97c2ad9f726b66b3e313d242c438958 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI=5
+
 inherit toolchain-funcs
 
 DESCRIPTION="Extracts files from Microsoft cabinet archive files"
@@ -16,17 +17,19 @@ IUSE="extras"
 
 RDEPEND="extras? ( dev-lang/perl )"
 
-# the code attempts to set up a fnmatch replacement, but then fails to code
-# it properly leading to undefined references to rpl_fnmatch().  This may be
-# removed in the future if building still works by setting "yes" to "no".
-export ac_cv_func_fnmatch_works=yes
+src_prepare() {
+       # the code attempts to set up a fnmatch replacement, but then fails to code
+       # it properly leading to undefined references to rpl_fnmatch().  This may be
+       # removed in the future if building still works by setting "yes" to "no".
+       export ac_cv_func_fnmatch_works=yes
+}
 
 src_compile() {
        emake AR="$(tc-getAR)"
 }
 
 src_install() {
-       emake DESTDIR="${D}" install
+       default
        dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
        dohtml doc/wince_cab_format.html
        if use extras; then