dev-lang/jimtcl: Stop using awful multijob_* logic
authorMichał Górny <mgorny@gentoo.org>
Sun, 31 Dec 2017 10:04:26 +0000 (11:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 21:55:55 +0000 (22:55 +0100)
The multijob logic adds a lot of complex, unmaintained and fragile bash
code with little gain. Moreover, makes build logs unreadable
by interspersing output from multiple configure runs.

Bug: https://bugs.gentoo.org/613322

dev-lang/jimtcl/jimtcl-0.76.ebuild
dev-lang/jimtcl/jimtcl-9999.ebuild

index 3d5515b2e63dedb4ad1ea85eed2d69d2c3c22150..166bf52e88b0538d12569fc245f33e90a23b57f4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI="5"
 
-inherit multiprocessing eutils
+inherit eutils
 
 if [[ ${PV} == *9999 ]] ; then
        EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
@@ -40,15 +40,13 @@ src_prepare() {
 }
 
 src_configure() {
-       multijob_init
-       CCACHE=None multijob_child_init econf --with-jim-shared
+       CCACHE=None econf --with-jim-shared
        if use static-libs ; then
                # The build does not support doing both simultaneously.
                mkdir static-libs
                cd static-libs
-               CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+               CCACHE=None ECONF_SOURCE=${S} econf
        fi
-       multijob_finish
 }
 
 src_compile() {
index 3c79869f318ef572498e596f6c0fffd23ea6c63a..c3f079c046f3535a5758763bc92bbb991fdbf268 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI="5"
 
-inherit multiprocessing eutils
+inherit eutils
 
 if [[ ${PV} == *9999 ]] ; then
        EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
@@ -40,15 +40,13 @@ src_prepare() {
 }
 
 src_configure() {
-       multijob_init
-       CCACHE=None multijob_child_init econf --with-jim-shared
+       CCACHE=None econf --with-jim-shared
        if use static-libs ; then
                # The build does not support doing both simultaneously.
                mkdir static-libs
                cd static-libs
-               CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+               CCACHE=None ECONF_SOURCE=${S} econf
        fi
-       multijob_finish
 }
 
 src_compile() {