sci-mathematics/wxmaxima: version bump to 15.08.0
authorAndrey Grozin <grozin@gentoo.org>
Sat, 29 Aug 2015 13:47:54 +0000 (19:47 +0600)
committerAndrey Grozin <grozin@gentoo.org>
Sat, 29 Aug 2015 13:47:54 +0000 (19:47 +0600)
Package-Manager: portage-2.2.20.1

sci-mathematics/wxmaxima/Manifest
sci-mathematics/wxmaxima/wxmaxima-15.08.0.ebuild [new file with mode: 0644]

index 87c8ce24cac93370af2dc4a3f38811982f15c7f2..c48162b4c550ced9739e93c3d48136fc9079ce90 100644 (file)
@@ -1,2 +1,4 @@
 DIST wxMaxima-13.04.2.tar.gz 1652680 SHA256 29352db75dd3ff27393ab0971543fd0b3c3a9c330c2c8d07ebfd373741ded4eb SHA512 36d035282aca8d40d9f5950c21e8e3abe8d3a76ffbb91f6436a3588e252ca2455c4c1c4e5eed4111888f917406ac758f551198ca97acb67bcc6655e579db20aa WHIRLPOOL 7579a5d7b72e0c10f9162b92da03b2f4f51052cf8800fc0c01312718cfc31c0d8ff608aff6f873e07b46247a2c2ad7dc666e0e469dda1f1a8e8af52629a6e69d
 DIST wxmaxima-15.04.0.tar.gz 4990313 SHA256 c178067a2f75d91dd378f88b4d0f87af6b2705ca32bea509d63e7347b2a1d21e SHA512 1a899259698da38f97a1859ba0526406cbc654a130dc1d18e01cf248ac4d7292c82cb00dd92ce2fac2c3cfc002788fdef0a6a4f95eca54b9096efc73c6aa45b7 WHIRLPOOL 225456c073b1aa87d2e599b9c63244ff7c97378fb6b5a60fcb8730655d193a0f032b27a1264e12eefb4abf08389f2337a11c380b6d89af2de9a4fb6e14f614dc
+DIST wxmaxima-15.08.0-missing.tar.bz2 16172 SHA256 d39d1a7937db05a4ae3e6a6d38a4079e93fb95b5533db7254de7dec7d24527db SHA512 195de1bcc4b469094716e0e417cf6431abe9f67e467c71fe51c4bed9990c613d5487cbcdda18d1df7f50e5e1b0abec7578e1091cc4999d95ba6a5f8849d826e2 WHIRLPOOL 34964f7ba5a1c9e5f2ab05b857c31b441eee43a127dc123337174509c71b7f80313e111b967abba47579021c52f27c71812c85efdf7a8429ad4e1e6c51f62db8
+DIST wxmaxima-15.08.0.tar.gz 5555560 SHA256 e6905b8e306b575e8e38b02a0e81de38be6d154d1349a455e01fbec28b21b27c SHA512 b13df571978c354ef420c613717149e3235bd5343746c12f2193eb0599f417b04cdb01e87e97ef2ed72bfd090b6ec6871c834fdb74074a3d5fb0f68bbe942263 WHIRLPOOL a2a1ae200eebb6d54a3c96cbd1c304b37c4a759ccc15983b3910d3aad1864d6c80d39e7e688198d4f3dd7c36bb9a8b2795a9610475858207b90482887219906a
diff --git a/sci-mathematics/wxmaxima/wxmaxima-15.08.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-15.08.0.ebuild
new file mode 100644 (file)
index 0000000..cdbdbcd
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+       https://dev.gentoo.org/~grozin/${P}-missing.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+       dev-libs/libxml2:2
+       x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+       media-fonts/jsmath
+       sci-visualization/gnuplot[wxwidgets]
+       sci-mathematics/maxima"
+
+src_prepare() {
+       local i
+
+       # consistent package names
+       sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+               -i Makefile.in data/Makefile.in test/Makefile.in || die "sed failed"
+
+       sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+               -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Dirstructure.cpp src/Dirstructure.h \
+               || die "sed failed"
+
+       # correct gettext behavior
+       if [[ -n "${LINGUAS+x}" ]] ; then
+               for i in $(cd "${S}"/locales ; echo *.mo) ; do
+                       if ! has ${i%.mo} ${LINGUAS} ; then
+                               sed -i \
+                                       -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+                                       -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+                                       locales/Makefile.in || die
+                       fi
+               done
+       fi
+}
+
+src_configure() {
+       econf \
+               --enable-printing \
+               --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+       default
+       doicon -s 128 data/wxmaxima.png
+       make_desktop_entry wxmaxima wxMaxima wxmaxima
+       dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       fdo-mime_desktop_database_update
+}