dev-tcltk/togl: EAPI 7
authorTupone Alfredo <tupone@gentoo.org>
Fri, 18 Oct 2019 12:42:38 +0000 (14:42 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 18 Oct 2019 12:42:38 +0000 (14:42 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/togl/togl-2.0-r3.ebuild [new file with mode: 0644]

diff --git a/dev-tcltk/togl/togl-2.0-r3.ebuild b/dev-tcltk/togl/togl-2.0-r3.ebuild
new file mode 100644 (file)
index 0000000..5791c04
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+       dev-lang/tk:*
+       virtual/opengl
+       x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+       sed \
+               -e 's:-fomit-frame-pointer::g' \
+               -e 's:-O2::g' \
+               -e 's:-pipe::g' \
+               -i configure || die
+}
+
+src_configure() {
+       econf \
+               $(use_enable debug symbols) \
+               $(use_enable threads)
+}
+
+src_install() {
+       HTML_DOCS=( doc/* )
+       default
+}