dev-python/dogpile-cache: 0.9.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 2 May 2020 18:52:04 +0000 (13:52 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 2 May 2020 18:52:18 +0000 (13:52 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/dogpile-cache/Manifest
dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild [new file with mode: 0644]

index e99a04d37c8f6ee944cd9cb442e8e8946d8dc3db..d99d9b80966cb4d1bb0773965f0bb2bdcfab0837 100644 (file)
@@ -1 +1,2 @@
 DIST dogpile.cache-0.7.1.tar.gz 326127 BLAKE2B 358391033d1d22b2711052f1aa3003c0c5f2da42b33b3f4fbb2d582418b0b42695db5df638dabcb9ba81ba414d142ac7f52a6c80ea645f5fcba12ca21122a495 SHA512 39c0a1d3d5027bc61cc69eda46c846c72d09892b2de0ea2e9545b1f710911dce8726b4ee4a0daef0d3c409a16733920d437f6e833a5b3f55ccc80267bb0da39c
+DIST dogpile.cache-0.9.1.tar.gz 329015 BLAKE2B 23a33ccf024153e39bdccebefc33c866990733432abd2bdd715a0f180f0059a2ff8315024d59d3ad9c79a01561fda3a802a867d359961d7655bdf790556c7a2f SHA512 7d84325dd7ec2d85027472f07cddd51f495b75dc9dbbcbf26bad7aaabfee8c2da99e0c247851282b228528a87e54d98e04d8451a3ca3a571e84a4a2bb33e72f2
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..2f4d320
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/mako[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest