app-portage/unsymlink-lib: Bump to v13
authorMichał Górny <mgorny@gentoo.org>
Thu, 31 May 2018 20:33:17 +0000 (22:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 31 May 2018 20:43:55 +0000 (22:43 +0200)
app-portage/unsymlink-lib/Manifest
app-portage/unsymlink-lib/unsymlink-lib-13.ebuild [new file with mode: 0644]

index eca37bf3afc2c864bbd2e8be054a5f4955a54687..ece281cc9d6e60ef010b9f3c7719c9266d9a9fc4 100644 (file)
@@ -1 +1,2 @@
 DIST unsymlink-lib-12.tar.gz 8689 BLAKE2B 3c170886bfa3980ef0d51be1e3636afcd700aad94514a2783a1bf221970022fb4812640ac0c2f54e6b0d3b93244a64221b092768425faa1ddcfdc21ba76d9cd1 SHA512 e964cf8dae4107cbe0f5a304e693794d50316b914cca6cdf068ac3e715c8a6fab44d96ec38bd34e5c4f65dd169629bcaca3a0b6ce3256c3d40dbff69dac56fe5
+DIST unsymlink-lib-13.tar.gz 8736 BLAKE2B 5b44112299232185f3f7a5d88057caa7e9161ca03a3e79bebd9dbf70a61ddde255d3a24679b9004cc572fedcfc24ffeb42693319e5dfa1f8371f8fed1408b15d SHA512 c87676b80259f2a20fde257e2b090380c3b04be1542a5a92832487327b8d1eb737059a6e6898f713fa378b792e23d2896280b94cb00d7961a0beba81cd6b3bd2
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-13.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-13.ebuild
new file mode 100644 (file)
index 0000000..44bf452
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       || (
+               sys-apps/portage[${PYTHON_USEDEP}]
+               sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+       )"
+
+src_install() {
+       python_doscript unsymlink-lib
+       dodoc README
+}