dev-python/cli_helpers: Sync the live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 13:09:47 +0000 (15:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 13:09:47 +0000 (15:09 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cli_helpers/cli_helpers-9999.ebuild

index a781b76eb170b6035403a6d19e42589c4ccf3a59..edaf342667d6735ddac0877cb0d532c7d831b945 100644 (file)
@@ -1,24 +1,38 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
 EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
 inherit distutils-r1 git-r3
 
 DESCRIPTION="Python helpers for common CLI tasks"
-
 HOMEPAGE="http://cli-helpers.rtfd.io/"
 SRC_URI=""
+
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
 IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
 RDEPEND="
-       >=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
+       >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
        >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
        >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+       dev-python/wcwidth[${PYTHON_USEDEP}]
 "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               >=dev-python/mock-2[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}