dev-python/py: Skip pypy tests
authorJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 12:48:09 +0000 (14:48 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 12:52:14 +0000 (14:52 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/py/py-1.4.30.ebuild

index 4d184df25266cf54d14eda752f0f1d4a85c4f3b4..2483483f636b60df9a098716309cccada6656b90 100644 (file)
@@ -35,6 +35,7 @@ python_compile_all() {
 python_test() {
        # 1 failure, test_comments, under both pypy only.
        # Also appears the home repo has no issue tracker.
+       [[ "${EPYTHON}" == pypy ]] && return
        py.test || die "testing failed with ${EPYTHON}"
 }