ros-meta/common_tutorials: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 16:13:54 +0000 (18:13 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 16:13:54 +0000 (18:13 +0200)
Package-Manager: portage-2.2.21

ros-meta/common_tutorials/Manifest [new file with mode: 0644]
ros-meta/common_tutorials/common_tutorials-0.1.8.ebuild [new file with mode: 0644]
ros-meta/common_tutorials/common_tutorials-9999.ebuild [new file with mode: 0644]
ros-meta/common_tutorials/metadata.xml [new file with mode: 0644]

diff --git a/ros-meta/common_tutorials/Manifest b/ros-meta/common_tutorials/Manifest
new file mode 100644 (file)
index 0000000..c0f80a8
--- /dev/null
@@ -0,0 +1 @@
+DIST common_tutorials-0.1.8.tar.gz 10591 SHA256 5be04cdcfbc569d7b89c306628fd4414a3e2972ad2154548df2b86d4056393d9 SHA512 a0a2e8a7aba3415bf133e95e7d1b72cf5ee81efa962003ccaa2108fdfebd2a03044c60fd4daf73ca69f3a2975bd7fa9c60adfefc32d1b048da11e65aa613607c WHIRLPOOL dd60f2c2c760c4f3485ec670af0a0140569535640886268f329e6088fa19279703489b361d51ba9bbd8cb05194f63376b11983e1709e1f5063dc6e28453a0685
diff --git a/ros-meta/common_tutorials/common_tutorials-0.1.8.ebuild b/ros-meta/common_tutorials/common_tutorials-0.1.8.ebuild
new file mode 100644 (file)
index 0000000..e144e64
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage that contains common tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/actionlib_tutorials
+       dev-ros/nodelet_tutorial_math
+       dev-ros/pluginlib_tutorials
+       dev-ros/turtle_actionlib
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/common_tutorials/common_tutorials-9999.ebuild b/ros-meta/common_tutorials/common_tutorials-9999.ebuild
new file mode 100644 (file)
index 0000000..e144e64
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage that contains common tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/actionlib_tutorials
+       dev-ros/nodelet_tutorial_math
+       dev-ros/pluginlib_tutorials
+       dev-ros/turtle_actionlib
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/common_tutorials/metadata.xml b/ros-meta/common_tutorials/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>