dev-python/nltk: Remove old (drop to ~arch)
authorMichał Górny <mgorny@gentoo.org>
Mon, 13 Apr 2020 07:55:14 +0000 (09:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 13 Apr 2020 10:32:13 +0000 (12:32 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nltk/Manifest
dev-python/nltk/metadata.xml
dev-python/nltk/nltk-3.2.5.ebuild [deleted file]

index 00cbf89f2463d631de2fbd8d419459c5a5660c04..aa8a421a2c180ad726c375fae83153cfed5eb346 100644 (file)
@@ -1,2 +1 @@
-DIST nltk-3.2.5.tar.gz 1188856 BLAKE2B 316e5955d2f90c351673ee9d3f0cc159babbcae08104518db62e796b422dcbf51668001b06b5d5dc399613d4db0ed39ff7dd15ad15d6f6c64e10c73a4d53bc06 SHA512 967b209ce3dde5296dafac16b91bff3894ff1a3f073c76974fd9193912597c82d2d1c50d4419052da77ab66f798f230f725b83f31368a95cacf94d46e45055de
 DIST nltk-3.4.5.tar.gz 2821481 BLAKE2B 9d3d6df9a951b4dfbfec335386ba0fb13c484c74a066141ebdfdb541fbec421dd72163d4028e239abd58f95a73e0eef5861574fa9955e4ee11f2c4598c895f59 SHA512 0ca24cd2154e47a8c50fe8e2426fa01c80904ece4100b07cdb4e5835e423e31968e96f0e750e1936f1e758a608596c560aaaee05b844b334f6179249db05f969
index 4bca3859ebd09b7005830e1b21bb26fae7aa2dba..7cfca4fc39acce194709544038fa555925a4e3f2 100644 (file)
@@ -5,9 +5,6 @@
     <email>python@gentoo.org</email>
     <name>Python</name>
   </maintainer>
-  <use>
-    <flag name="numpy">Use numpy for the saved word tokenizer</flag>
-  </use>
   <upstream>
     <remote-id type="google-code">nltk</remote-id>
     <remote-id type="pypi">nltk</remote-id>
diff --git a/dev-python/nltk/nltk-3.2.5.ebuild b/dev-python/nltk/nltk-3.2.5.ebuild
deleted file mode 100644 (file)
index d683c25..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,tk?,xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Natural Language Toolkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="https://www.nltk.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="numpy test tk"
-
-RDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# currently requires linguistic data to be downloaded separately
-RESTRICT="test"
-
-python_test() {
-       nosetests || die "Tests failed under ${EPYTHON}"
-}