dev-python/pyilmbase: Fix configure w/ >=boost-1.70
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 May 2019 12:05:24 +0000 (14:05 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 16:59:31 +0000 (18:59 +0200)
Closes: https://bugs.gentoo.org/684770
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pyilmbase/pyilmbase-2.3.0.ebuild

index fda4c62db801b693daf5200a87e04001923b4b09..f0a627779b31deafe83e2268fe112b3685a10cf1 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -38,10 +38,17 @@ src_prepare() {
 }
 
 src_configure() {
+       local boostpython_ver="${EPYTHON:6}"
+       if has_version ">=dev-libs/boost-1.70.0"; then
+               boostpython_ver="${boostpython_ver/./}"
+       else
+               boostpython_ver="-${boostpython_ver}"
+       fi
+
        local myeconfargs=(
                --with-boost-include-dir="${EPREFIX}/usr/include/boost"
                --with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
-               --with-boost-python-libname="boost_python-${EPYTHON:6}"
+               --with-boost-python-libname="boost_python${boostpython_ver}"
                $(use_with numpy)
        )