dev-python/semantic_version: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 07:50:41 +0000 (09:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 08:18:58 +0000 (10:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/semantic_version/Manifest
dev-python/semantic_version/semantic_version-2.8.2.ebuild [deleted file]

index 610a9ed5b05da7db2c628381db7cdd4de7ee3a1f..e2f29ab33f4d782cac40e43ff97fc8d2ae6677fa 100644 (file)
@@ -1,2 +1 @@
-DIST semantic_version-2.8.2.tar.gz 49243 BLAKE2B 73c66696b2fd6e30dc74bba6f1d4d84d71bf470f8ecd2ab93b4225f573bb0575f797b573d8fa6605ff35636de713a8f69522a2719949cf0bfebd0791ab5bae99 SHA512 f54ad2bb2e8392e154718c3dff8e7a7fa7663d7df0ab4b196444e0ad22440fe9d9a3abe9043824c0e0121f9051121b8c9d67f76a615aa5348c321e217b3a5dcd
 DIST semantic_version-2.8.4.tar.gz 49774 BLAKE2B 30dc1bbca9e24db993e2c9eae2ba05e7a102ba8baae10bc49640d74a3fe9ff943b7606b7c7cbad3d7b25d65a10df7ab587179b5a9bfe73822eb62b945074db23 SHA512 2ed9a8ae03384731865c0b160a9bc92f9c877b610a4ecf15c30969886f15e7cdf77cf384997f96126a8a77534e032c70f587c835fe288fe4ab3e9e2061cb6f47
diff --git a/dev-python/semantic_version/semantic_version-2.8.2.ebuild b/dev-python/semantic_version/semantic_version-2.8.2.ebuild
deleted file mode 100644 (file)
index 3f78ef9..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library providing a few tools handling SemVer in Python"
-HOMEPAGE="https://pypi.org/project/semantic_version/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-#SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="doc test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RESTRICT="!test? ( test )"
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       # The django test hangs
-       pytest -vv --ignore tests/test_django.py\
-               || die "tests failed with ${EPYTHON}"
-}