Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 01:59:02 +0000 (01:59 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 01:59:02 +0000 (01:59 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_bandwidth/ChangeLog
net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild

index 3a7dd3d4a719d0863dd709bde9e96af41dd9a5a5..6a21daa914486e8ac2ff159f060755ee55de2a8e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-www/mod_bandwidth
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bandwidth/ChangeLog,v 1.15 2006/12/02 23:05:23 beandog Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bandwidth/ChangeLog,v 1.16 2007/01/14 01:59:02 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+  -files/mod_bandwidth-2.0.4-register.patch,
+  -files/mod_bandwidth-2.0.5-register.patch, -files/mod_bandwidth.conf,
+  mod_bandwidth-2.0.5-r1.ebuild:
+  Cleanup.
 
   02 Dec 2006; Steve Dibb <beandog@gentoo.org>
   mod_bandwidth-2.0.5-r1.ebuild:
index 281b408709795861dbf26b55ef8cf8a8bf5d4109..05658986b6626a8df63160d84a45c882631be4c1 100644 (file)
@@ -1,31 +1,31 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild,v 1.5 2006/12/02 23:05:23 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild,v 1.6 2007/01/14 01:59:02 chtekk Exp $
 
-inherit eutils apache-module
+inherit apache-module
 
-DESCRIPTION="Bandwidth Management Module for Apache"
+DESCRIPTION="Bandwidth Management Module for Apache1."
 HOMEPAGE="http://www.cohprog.com/v3/bandwidth/intro-en.html"
-SRC_URI="ftp://ftp.cohprog.com/pub/apache/module/1.3.0/mod_bandwidth.c"
+SRC_URI="ftp://ftp.cohprog.com/pub/apache/module/1.3.0/${PN}.c"
 
 KEYWORDS="~amd64 ppc ~sparc x86"
-DEPEND=""
 LICENSE="Apache-1.1"
 SLOT="0"
 IUSE=""
 
+DEPEND=""
+RDEPEND=""
+
 APACHE1_MOD_CONF="10_${PN}"
 APACHE1_MOD_DEFINE="BANDWIDTH"
 
 need_apache1
 
 src_unpack() {
-       mkdir -p ${S} && cp ${DISTDIR}/${A} ${S} || die
-       cd ${S} || die
+       cp -f "${DISTDIR}/${PN}.c" "${S}/" || die "source copy failed"
 }
 
 pkg_postinst() {
-       # empty dirs
-       install -m0755 -o apache -g apache -d ${ROOT}/var/cache/mod_bandwidth/{link,master}
+       install -m0755 -o apache -g apache -d "${ROOT}"/var/cache/${PN}/{link,master}
        apache1_pkg_postinst
 }