dev-lang/mono-basic: bump to version 4.8
authorConrad Kostecki <conrad@kostecki.com>
Mon, 22 Apr 2019 15:36:41 +0000 (17:36 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:16:07 +0000 (22:16 +0200)
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/11787
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/mono-basic/Manifest
dev-lang/mono-basic/mono-basic-4.8.ebuild [new file with mode: 0644]

index e75ec9d9012dc593dce0cc787c711fb4ab548376..8a07f767eff273ce8a352f114d0a6c6747c24bf0 100644 (file)
@@ -1 +1,2 @@
 DIST mono-basic-4.7.tar.bz2 2051806 BLAKE2B 8d8beb26bfc79c5ff648d671fc92d0f15204694ac735d1ab0c375547f7f4a89519f24bc512ecc16ae93455c7c28978ef2112804335a02b9ccb63e537298e11d5 SHA512 c690f81d7af64d1592bc480be230abc93480728288291fe85de5c8b273eb6127d619c3bd02f2acd285b9b055ef4f2970a764b34f49f15e59ed238d01c151c99a
+DIST mono-basic-4.8.tar.gz 3282183 BLAKE2B 01323912b4bca2ef9544e084e6a58f9168394a8665bd6ba65ee6e784da778e46d769a1d0b5292aeceefe877aa47aefd5104c52e779e0f57f04d3207b4d682155 SHA512 9fbfcc28337b8bce6bc274a0da190779f0a3bfb185b07b79d2e2d5415ba02ac3c56eb3c2752980c3c8bfcef13d23aa18af873ece4f70bcc03aa96f08b36f6702
diff --git a/dev-lang/mono-basic/mono-basic-4.8.ebuild b/dev-lang/mono-basic/mono-basic-4.8.ebuild
new file mode 100644 (file)
index 0000000..83dc3bc
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mono-env
+
+EGIT_COMMIT="e31cb702937a0adcc853250a0989c5f43565f9b8"
+
+DESCRIPTION="Visual Basic Compiler and Runtime"
+HOMEPAGE="https://www.mono-project.com/docs/about-mono/languages/visualbasic/"
+SRC_URI="https://github.com/mono/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2 MIT"
+SLOT="0"
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}"
+
+# See https://github.com/mono/mono-basic/issues/49
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"