media-sound/pulseeffects: fix gcc10 builds
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 26 May 2020 16:03:05 +0000 (11:03 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 26 May 2020 16:03:18 +0000 (11:03 -0500)
Closes: https://bugs.gentoo.org/725478
Package-Manager: Portage-2.3.99, Repoman-2.3.22
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch [new file with mode: 0644]
media-sound/pulseeffects/metadata.xml
media-sound/pulseeffects/pulseeffects-4.7.2-r1.ebuild [moved from media-sound/pulseeffects/pulseeffects-4.7.2.ebuild with 97% similarity]

diff --git a/media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch b/media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch
new file mode 100644 (file)
index 0000000..fb8080d
--- /dev/null
@@ -0,0 +1,32 @@
+From dbaea05da683f7bfcd7960c88b1b7d13379435c0 Mon Sep 17 00:00:00 2001
+From: Vasiliy Glazov <vascom2@gmail.com>
+Date: Tue, 24 Mar 2020 10:54:09 +0300
+Subject: [PATCH] Fix build with GCC 10
+
+This fix build error:
+```
+../include/plugin_base.hpp:10:25: error: expected ')' before 'tag'
+   10 |   PluginBase(std::string tag, std::string plugin_name, const std::string& schema);
+      |             ~           ^~~~
+      |                         )
+../include/plugin_base.hpp:17:8: error: 'string' in namespace 'std' does not name a type
+   17 |   std::string log_tag, name;
+      |        ^~~~~~
+../include/plugin_base.hpp:7:1: note: 'std::string' is defined in header '<string>'; did you forget to '#include <string>'?
+```
+---
+ include/plugin_base.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/plugin_base.hpp b/include/plugin_base.hpp
+index a2356fbf..79fd5452 100644
+--- a/include/plugin_base.hpp
++++ b/include/plugin_base.hpp
+@@ -4,6 +4,7 @@
+ #include <gio/gio.h>
+ #include <gst/gst.h>
+ #include <sigc++/sigc++.h>
++#include <string>
+ class PluginBase {
+  public:
index e771c24111429616ffd7f1255fee3021f771539a..c0da3601cd32b7bd89a2030163f94e6342c275bb 100644 (file)
@@ -5,11 +5,6 @@
                <email>prometheanfire@gentoo.org</email>
                <name>Matthew Thode</name>
        </maintainer>
-       <maintainer type="person">
-               <email>jpizarrocallejas@gmail.com</email>
-               <name>Jorge Pizarro Callejas</name>
-               <description>Jorgicio Gentoo Overlay</description>
-       </maintainer>
        <use>
                <flag name="bs2b">Enable use of media-libs/libbs2b</flag>
                <flag name="calf">Enable use of media-plugins/calf for adding various FX</flag>
similarity index 97%
rename from media-sound/pulseeffects/pulseeffects-4.7.2.ebuild
rename to media-sound/pulseeffects/pulseeffects-4.7.2-r1.ebuild
index 112dd9a47361fc5ef338f4ed29e4abb7b4ff5410..b12d12b7438a2934124d7c4935c97116eefe3528 100644 (file)
@@ -59,6 +59,10 @@ BDEPEND="
        virtual/pkgconfig
 "
 
+PATCHES=(
+       "${FILESDIR}/patch-4.7.2-gcc10.patch"
+)
+
 pkg_postinst() {
        gnome2_gconf_install
        gnome2_schemas_update