media-gfx/opentoonz: initial commit with the version 1.1.2
authorTakuto Yoshida <otakuto.gentoo@gmail.com>
Thu, 16 Mar 2017 23:27:58 +0000 (19:27 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Thu, 16 Mar 2017 23:32:24 +0000 (19:32 -0400)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-gfx/opentoonz/Manifest [new file with mode: 0644]
media-gfx/opentoonz/metadata.xml [new file with mode: 0644]
media-gfx/opentoonz/opentoonz-1.1.2.ebuild [new file with mode: 0644]

diff --git a/media-gfx/opentoonz/Manifest b/media-gfx/opentoonz/Manifest
new file mode 100644 (file)
index 0000000..bb11199
--- /dev/null
@@ -0,0 +1 @@
+DIST opentoonz-1.1.2.tar.gz 36777909 SHA256 e9943abbd49befb5c8963fd7cb744b6c5b93a4faa02c8564610b848d189ea029 SHA512 800a741cb40e7dede79ef92705fc8fe3a23524c8a4397c30f80a81a7513c98606fb1bb5574188969ba08cfe8995d679f9fc5ecb696a6ac14c48aa2646a2c871e WHIRLPOOL 2664e8f087163c4db3413135c7943d290088c116f91f07d414838b3efa2039fae2cf8e1fc1bf1521de580dc8d561cf16c4aee34cf165b2fd920ec02456e8b404
diff --git a/media-gfx/opentoonz/metadata.xml b/media-gfx/opentoonz/metadata.xml
new file mode 100644 (file)
index 0000000..3392e3f
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>otakuto.gentoo@gmail.com</email>
+               <name>Tact Yoshida</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/media-gfx/opentoonz/opentoonz-1.1.2.ebuild b/media-gfx/opentoonz/opentoonz-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..104404d
--- /dev/null
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+1;2802;0c# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An open-source full-featured 2D animation creation software"
+HOMEPAGE="https://github.com/opentoonz/opentoonz"
+SRC_URI="https://github.com/opentoonz/opentoonz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD libtiff"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       app-arch/lz4:=
+       >=dev-libs/boost-1.55.0:=
+       dev-libs/lzo:2=
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtmultimedia:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtopengl:5
+       dev-qt/qtprintsupport:5
+       dev-qt/qtscript:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtxml:5
+       media-libs/freeglut:=
+       media-libs/freetype:2=
+       media-libs/glew:=
+       media-libs/libjpeg-turbo:=
+       media-libs/libpng:=
+       media-libs/libsdl2:=
+       sci-libs/blas-reference:=
+       >=sci-libs/superlu-4.1:=
+       sys-libs/zlib:=
+       virtual/libusb:=
+       virtual/opengl
+"
+DEPEND="
+       $RDEPEND
+       virtual/pkgconfig
+       dev-qt/linguist-tools:5
+"
+
+CMAKE_USE_DIR="${S}"/toonz/sources
+
+src_configure()
+{
+       local mycmakeargs=(
+               -DTIFF_LIBRARY="${S}/thirdparty/tiff-4.0.3/libtiff/.libs/libtiff.a"
+               -DSUPERLU_INCLUDE_DIR="${EPREFIX%/}/usr/include/superlu"
+               -DLZO_INCLUDE_DIR="${EPREFIX%/}/usr/include/lzo"
+               -DCMAKE_SKIP_RPATH=ON
+       )
+
+       # The upstream uses their own modified libtiff
+       # See: https://github.com/opentoonz/opentoonz/blob/master/doc/how_to_build_linux.md#building-libtiff
+       cd thirdparty/tiff-4.0.3 || die
+       econf \
+               --with-pic \
+               --disable-jbig \
+               --enable-static \
+               --disable-shared
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cd "${S}"/thirdparty/tiff-4.0.3 || die
+       emake
+
+       cmake-utils_src_compile
+}
+
+pkg_postinst()
+{
+       elog "It is supposedly optional but some files are"
+       elog "actually required to run the executable properly."
+       elog
+       elog "The .config/OpenToonz/ directory in your home folder"
+       elog "will contain your settings, work and other files."
+       elog
+       elog "We need to create it from the command-line:"
+       elog
+       elog "$ mkdir -p \$HOME/.config/OpenToonz"
+       elog "$ cp -r /usr/share/opentoonz/stuff/ \$HOME/.config/OpenToonz/"
+}