sys-apps/thunderbolt-software-user-space: EAPI-7 bump, fix DEPENDs
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 30 Sep 2019 21:17:51 +0000 (23:17 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 6 Oct 2019 11:23:41 +0000 (13:23 +0200)
Add missing dev-libs/boost slot operator.
app-text/txt2tags is not needed at runtime.
Fix typo.

Bug: https://bugs.gentoo.org/648312
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild [new file with mode: 0644]

diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
new file mode 100644 (file)
index 0000000..5d97235
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="Thunderbolt(TM) user-space components"
+HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="app-text/txt2tags"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+       CONFIG_CHECK="THUNDERBOLT"
+       ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
+       CONFIG_CHECK="HOTPLUG_PCI"
+       ERROR_HOTPLUG_PCI="Thunderbolt needs pci hotplug support, so please enable it."
+       check_extra_config
+}