sys-libs/libcap-ng: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 16:19:24 +0000 (18:19 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 16:19:33 +0000 (18:19 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/libcap-ng/Manifest
sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild [deleted file]
sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild [deleted file]

index a47182634d146cc1bf89479b4e4c8c1cb0728972..b33a3ee0224effc5da309bc3cf5465ea87e29ab2 100644 (file)
@@ -1,3 +1 @@
 DIST libcap-ng-0.7.10.tar.gz 450243 BLAKE2B 8eb21b0309e46b05fa42752b9c814d90bc1eda4852ac7a4975868c279764431a8d5eafc53e50998470f622e2a59e2b4c6c2ac1ac20525c6fcd0633b09b113012 SHA512 1b93c7f5c20ae5cc705fe5244af3e299454e988388cda95f006e248d97c0713e77da2a81c67ecf15755f3958df373fc6d1ca14197d6357ab1f2d8c3a0fd12def
-DIST libcap-ng-0.7.8.tar.gz 447946 BLAKE2B a26af2dcdd1af26cf03ca668dc95eed7bc1d0344729031497f46bba865bcb23ded2f1ea2ca5cb500b9419bbbd7ed75501921485257a3c8930d156a94e0a2c1c1 SHA512 c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756
-DIST libcap-ng-0.7.9.tar.gz 449038 BLAKE2B 3f84e5078d5d443cb61358c49405e4f16ff82a56e1c96d5127b522613b1b5c56a566a01b14b40055eca85f13b37f3d795248a506c54ac4612ab184a94addc365 SHA512 095edabaf76a943aab0645b843b14e20b1733ba1d47a8e34d82f6586ca9a1512ba2677d232b13dd3900b913837401bb58bf74481970e967ba19041959dc43259
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild
deleted file mode 100644 (file)
index b4fa6ac..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-PYTHON_COMPAT=( python3_6 )
-
-inherit autotools-utils flag-o-matic python-r1
-
-DESCRIPTION="POSIX 1003.1e capabilities"
-HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
-SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~x86-linux"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
-       sys-kernel/linux-headers
-       python? ( >=dev-lang/swig-2 )"
-
-RESTRICT="test"
-
-src_prepare() {
-       sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
-
-       autotools-utils_src_prepare
-
-       use sparc && replace-flags -O? -O0
-}
-
-src_configure() {
-       # set up the library build
-       local myeconfargs=( --without-python --without-python3 )
-       autotools-utils_src_configure
-
-       # set up python bindings build(s)
-       if use python ; then
-               setup_python_flags_configure() {
-                       if [[ ${EPYTHON} == python2* ]] ; then
-                               myeconfargs=( --with-python --without-python3 )
-                       else
-                               myeconfargs=( --with-python --with-python3 )
-                       fi
-                       autotools-utils_src_configure
-               }
-
-               python_foreach_impl setup_python_flags_configure
-       fi
-}
-
-src_compile() {
-       autotools-utils_src_compile
-
-       if use python; then
-               python_compile() {
-                       local CFLAGS=${CFLAGS}
-
-                       python_is_python3 || CFLAGS+=" -fno-strict-aliasing"
-
-                       emake "${@}" \
-                               -C "${BUILD_DIR}"/bindings/python
-               }
-
-               # help build system find the right objects
-               python_foreach_impl python_compile \
-                       VPATH="${BUILD_DIR}"/bindings/python \
-                       LIBS="${BUILD_DIR}"/src/libcap-ng.la
-       fi
-}
-
-src_test() {
-       if [[ "${EUID}" -eq 0 ]]; then
-               ewarn "Skipping tests due to root permissions."
-               return
-       fi
-
-       autotools-utils_src_test
-
-       if use python; then
-               python_foreach_impl \
-                       autotools-utils_src_compile -C bindings/python check \
-                       VPATH="${BUILD_DIR}"/bindings/python:"${S}"/bindings/python/test
-       fi
-}
-
-src_install() {
-       autotools-utils_src_install
-
-       if use python; then
-               python_foreach_impl \
-                       autotools-utils_src_install -C bindings/python \
-                       VPATH="${BUILD_DIR}"/bindings/python
-       fi
-}
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild
deleted file mode 100644 (file)
index 55399ea..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit autotools flag-o-matic python-r1
-
-DESCRIPTION="POSIX 1003.1e capabilities"
-HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
-SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
-       sys-kernel/linux-headers
-       python? ( >=dev-lang/swig-2 )"
-
-src_prepare() {
-       default
-       if use prefix ; then
-               sed -i "s@cat /usr@cat ${EPREFIX}/usr@" bindings/python*/Makefile.am || die
-               eautomake #668722
-       fi
-}
-
-src_configure() {
-       use sparc && replace-flags -O? -O0
-
-       local ECONF_SOURCE="${S}"
-
-       local myconf=(
-               $(use_enable static-libs static)
-       )
-
-       local pythonconf=( --without-python --without-python3 )
-
-       # set up python bindings build(s)
-       if use python ; then
-               setup_python_flags_configure() {
-                       if python_is_python3; then
-                               pythonconf=( --without-python --with-python3 )
-                       else
-                               pythonconf=( --with-python --without-python3 )
-                               local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-                       fi
-                       run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
-               }
-
-               python_foreach_impl setup_python_flags_configure
-       else
-               local BUILD_DIR=${WORKDIR}/build
-               run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
-       fi
-}
-
-src_compile() {
-       if use python; then
-               python_foreach_impl run_in_build_dir emake
-       else
-               local BUILD_DIR=${WORKDIR}/build
-               emake -C "${BUILD_DIR}"
-       fi
-}
-
-src_test() {
-       if [[ "${EUID}" -eq 0 ]]; then
-               ewarn "Skipping tests due to root permissions."
-               return
-       fi
-
-       if use python; then
-               python_foreach_impl run_in_build_dir emake check
-       else
-               local BUILD_DIR=${WORKDIR}/build
-               emake -C "${BUILD_DIR}" check
-       fi
-}
-
-src_install() {
-       if use python; then
-               python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
-       else
-               local BUILD_DIR=${WORKDIR}/build
-               emake -C "${BUILD_DIR}" DESTDIR="${D}" install
-       fi
-       find "${ED}" -name '*.la' -delete || die
-}