app-editors/gedit-plugins: Port to python-single-r1
authorDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 18:54:25 +0000 (19:54 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 19:10:58 +0000 (20:10 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4175

app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild

index efdc73d945d9843ce6671a8dbd7d9c7df6f60c3d..c7b357851c26f91b86258276f7012193b7f3ccb4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
 PYTHON_REQ_USE="xml"
 VALA_MIN_API_VERSION="0.28"
 
-inherit eutils gnome2 multilib python-r1 vala
+inherit eutils gnome2 multilib python-single-r1 vala
 
 DESCRIPTION="Official plugins for gedit"
 HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
@@ -22,7 +22,7 @@ IUSE="+python ${IUSE_plugins}"
 REQUIRED_USE="
        charmap? ( python )
        git? ( python )
-       python? ( ^^ ( $(python_gen_useflags '*') ) )
+       python? ( ${PYTHON_REQUIRED_USE} )
        terminal? ( python )
        zeitgeist? ( python )
 "
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
 "
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
 }
 
 src_prepare() {
index cba41efe3e1cc1f827a95538335f9415cebc6f72..83a4559f736f117871bbff29d1b527497205e93c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
 PYTHON_REQ_USE="xml"
 VALA_MIN_API_VERSION="0.28"
 
-inherit eutils gnome2 multilib python-r1 vala
+inherit eutils gnome2 multilib python-single-r1 vala
 
 DESCRIPTION="Official plugins for gedit"
 HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
@@ -22,7 +22,7 @@ IUSE="+python ${IUSE_plugins}"
 REQUIRED_USE="
        charmap? ( python )
        git? ( python )
-       python? ( ^^ ( $(python_gen_useflags '*') ) )
+       python? ( ${PYTHON_REQUIRED_USE} )
        terminal? ( python )
        zeitgeist? ( python )
 "
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
 "
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
 }
 
 src_prepare() {