dev-python/flake8: Drop 2.5.4
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Jan 2020 21:55:25 +0000 (22:55 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Jan 2020 20:02:03 +0000 (21:02 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/flake8/Manifest
dev-python/flake8/flake8-2.5.4.ebuild [deleted file]

index a23e729810ebe7d1322b7abe0030c3a0d26ddaf1..5432131e6a910b8caf7f8721d11891b4aaee53b5 100644 (file)
@@ -1,3 +1,2 @@
-DIST flake8-2.5.4.tar.gz 81663 BLAKE2B 89bd5965fe1f6862cadbfc7b614a819a13d4ab147994485542ba519d6151ab11d4b496066c74141020858f468050e7b6dc3d6ce3a89ddf809e9cdc6d130984ef SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28
 DIST flake8-3.5.0.tar.gz 140608 BLAKE2B 938ad4406370da27155512355432edd23a824db1d6ee635591628fefad43ee1116256ae7f240496d93941800212ea2479be73fb9ee9bd03c9a54ab70bbce452f SHA512 ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
 DIST flake8-3.7.9.tar.gz 150123 BLAKE2B fd46710c0dcce7d3dcb3d5fc8ff7a83a35315679fa838e68abafd5bdc342c13218706fec0dac3fc9a6d919971f1f846c855f00cbd60c925e979378e431dace0b SHA512 c3c753ad050d8a8f87f7c28c8a1c953ed9bd04f08b09512d9323152b4eebb57d67fbfb0f5317d629174fa12fa234e1a86d6a633dd951fff6a45330b1c4f62850
diff --git a/dev-python/flake8/flake8-2.5.4.ebuild b/dev-python/flake8/flake8-2.5.4.ebuild
deleted file mode 100644 (file)
index 23f202f..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-LICENSE="MIT"
-SLOT="0"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
-       >=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
-       <dev-python/pyflakes-1.1[${PYTHON_USEDEP}]
-       >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
-       !=dev-python/pep8-1.6.1[${PYTHON_USEDEP}]
-       !=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${PDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
-               >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
-               <dev-python/mccabe-0.5[${PYTHON_USEDEP}]
-       )"
-PDEPEND="
-       >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
-       <dev-python/mccabe-0.5[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # This tests requires / assumes this version is already installed.
-       sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
-
-       # Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
-       sed -e 's:, != 1.6.2::' -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}